Bug 849150 - spacewalk-channel displays inappropriate message when restrict action takes place.
spacewalk-channel displays inappropriate message when restrict action takes...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Client (Show other bugs)
550
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Stephen Herr
Jiří Mikulka
:
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2012-08-17 09:00 EDT by Dimitar Yordanov
Modified: 2014-10-06 09:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 849219 (view as bug list)
Environment:
Last Closed: 2013-10-01 17:53:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitar Yordanov 2012-08-17 09:00:23 EDT
Description of problem:
Command "spacewalk-channel" seems to be too verbose when simply restricts the user from a certain action. In this case messages like "An error has occurred while processing your request." are inappropriate.

Version-Release number of selected component (if applicable):
rhn-setup-1.0.0-71.el6.noarch.rpm
rhn-setup-0.4.20-78.el5


How reproducible:
100%

Steps to Reproduce:
1. stalltie-sync -c rhel-x86_64-server-6 -c rhn-tools-rhel-x86_64-server-6 -c redhat-rhn-proxy-5.4-server-x86_64-6
2. Register client to Satellite
3. Execute the following command on the client.
  #spacewalk-channel --add -c redhat-rhn-proxy-5.4-server-x86_64-6 --user admin --password nimda
  
Actual results:

# spacewalk-channel --add -c redhat-rhn-proxy-5.4-server-x86_64-6 --user admin --password nimda
Error communicating with server. The message was:

Error Class Code: 73
Error Class Info: Satellite or Proxy channel can not be subscribed.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

Expected results:
# spacewalk-channel --add -c redhat-rhn-proxy-5.4-server-x86_64-6 --user admin --password nimda
Error communicating with server. The message was:

Error Class Code: 73
Error Class Info: Satellite or Proxy channel can not be subscribed.

Additional info:
Comment 1 Stephen Herr 2012-08-17 13:56:23 EDT
This is an incredibly easy thing to fix if we want to pull this into Sat 5.5.

All we have to do is change a rhnFault(73) to rhnFault(73, explain=0).

So there is virtually 0 risk of breaking something else if we're worried about regressions.
Comment 3 Jan Pazdziora 2013-03-12 11:59:50 EDT
Marking as MODIFIED, this was changed in Spacewalk 1.8 via bug 849219.
Comment 6 Clifford Perry 2013-10-01 17:53:32 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.