Bug 849158 - Named will not shut down after filesystem corruption causes /var to remount read-only.
Named will not shut down after filesystem corruption causes /var to remount r...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bind (Show other bugs)
5.4
Unspecified Linux
unspecified Severity low
: rc
: ---
Assigned To: Adam Tkac
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 09:26 EDT by Moray.Henderson
Modified: 2013-04-30 19:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-18 09:04:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moray.Henderson 2012-08-17 09:26:35 EDT
Description of problem:
named will not shut down cleanly if /var partition has been remounted read-only (e.g. after filesystem corruption detected).

Version-Release number of selected component (if applicable):
bind-9.3.6-4.P1.el5_4.2

How reproducible:
Always

Steps to Reproduce:
1. Remount /var read-only
2. "service named stop" or "rndc halt" or "kill -TERM <pid>"
3.
  
Actual results:
Stop or halt command hangs; named remains active

Expected results:
named should shut down

Additional info:
All other daemons and services accessing /var can be stopped with service(8), although of course they complain they can't remove their /var/run or /var/lock files.  Only named requires a "kill -9".  If this causes the full OS shutdown process to hang, then it may prevent support personnel accessing the server remotely to try to fix it.
Comment 1 Adam Tkac 2013-03-18 09:04:43 EDT
Since RHEL 5 is now in production phase 2 (only important/critical bugs are fixed) and this is not important issue, I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.