Bug 849166 - Do not ship libdst
Do not ship libdst
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 10:29 EDT by Jiri Popelka
Modified: 2012-11-14 06:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-14 06:43:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jiri Popelka 2012-08-17 10:29:02 EDT
Until version 4.1 ISC DHCP was using its own library libdst for authentication of DHCP Messages (RFC 3118). This library implements HMAC-MD5 (RFC 2104).
Since 4.2 libdns from ISC BIND has been used for this purpose. On Fedora we ship libdns with bind-libs-lite package.

There's been no reason to ship libdst with dhcp-libs anymore.
Although I'm not sure why upstream still includes the code with DHCP and builds libdst by default it should be quite easy to remove it because nothing has been linking against it anymore.
Comment 1 Jiri Popelka 2012-08-17 12:07:26 EDT
Shawn Routhier's (ISC) response:

As I recall I left those directories in place in case somebody was
using them to build their own program. For example if somebody
had been constructing something similar to OMSHELL.

While I don't know of anybody doing so, it seemed harmless to
continue including the code.
Comment 2 Fedora Update System 2012-09-13 11:25:19 EDT
dhcp-4.2.4-15.P2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/dhcp-4.2.4-15.P2.fc18
Comment 3 Fedora Update System 2012-09-17 19:13:09 EDT
dhcp-4.2.4-15.P2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.