Bug 849186 - fix lease reacquire after failure
fix lease reacquire after failure
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sanlock (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Teigland
Haim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 11:52 EDT by David Teigland
Modified: 2014-01-12 19:53 EST (History)
6 users (show)

See Also:
Fixed In Version: sanlock-2.3-4.el6_3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 13:15:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Teigland 2012-08-17 11:52:47 EDT
Description of problem:

The paxos code was doing some unnecessary host_id checks when the same
host re-acquired a lease after it was uncleanly shut down previously.

test: existing failure/recovery tests should continue to work the same

commit
sanlock: fix paxos acquire host_id check

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 David Teigland 2012-08-21 16:00:42 EDT
To test this code path, a host needs to be holding a lease, and then be reset/restarted in some way such that it does not record the lease as free on storage, i.e. the lease on disk still shows that the host holds it, but the host has in fact lost the lease.  Once restarted, the host should be made to acquire the same lease.  At this point it will see that it's still the owner on disk, although with a previous generation.

A couple ways you could cause a host to be restarted without releasing a lease on disk:
- Disconnect the storage holding the lease from the host.
- Reset power on the host while it's holding a lease.
Comment 5 Leonid Natapov 2012-11-28 11:38:05 EST
storage disconnected from the host and reconnected after several minutes. the host acquired the same lease that it was holding before. 


sanlock-2.3-4.el6_3.x86_64
Comment 7 errata-xmlrpc 2012-12-04 13:15:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1507.html

Note You need to log in before you can comment on or make changes to this bug.