Bug 849192 - Breaking changes to AS5 Plugin -- This can break other plugins that depend on the AS5 plugin
Breaking changes to AS5 Plugin -- This can break other plugins that depend on...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Other (Show other bugs)
JON 3.1.0
Unspecified Unspecified
high Severity high
: ---
: JON 3.1.1
Assigned To: Stefan Negrea
Mike Foley
:
Depends On: 848800
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 12:16 EDT by Stefan Negrea
Modified: 2013-09-11 07:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 848800
Environment:
Last Closed: 2013-09-11 07:01:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stefan Negrea 2012-08-17 12:16:36 EDT
+++ This bug was initially created as a clone of Bug #848800 +++

Description of problem:


jopr-jboss-as-5-plugin-4.4.0.JON311-SNAPSHOT.signature-check.xml

<?xml version="1.0"?>
<diffreport>
  <difference binseverity="ERROR" srcseverity="ERROR" 
class="org.rhq.plugins.jbossas5.Ejb2BeanComponent" method="protected 
org.jboss.managed.api.ManagedComponent getManagedComponent()">In method 
'protected org.jboss.managed.api.ManagedComponent getManagedComponent()' the 
number of arguments has changed</difference>
  <difference binseverity="ERROR" srcseverity="ERROR" 
class="org.rhq.plugins.jbossas5.helper.CreateChildResourceFacetDelegate" 
method="public 
CreateChildResourceFacetDelegate(org.rhq.plugins.jbossas5.ProfileServiceComponent)">In 
method 'public 
CreateChildResourceFacetDelegate(org.rhq.plugins.jbossas5.ProfileServiceComponent)' 
the number of arguments has changed</difference>
</diffreport>

These should be fixed just in case the plugins that depend on AS5 plugin use
these methods.

--- Additional comment from snegrea@redhat.com on 2012-08-17 09:50:03 EDT ---

<difference binseverity="ERROR" srcseverity="ERROR" 
class="org.rhq.plugins.jbossas5.Ejb2BeanComponent" method="protected 
org.jboss.managed.api.ManagedComponent getManagedComponent()">In method 
'protected org.jboss.managed.api.ManagedComponent getManagedComponent()' the 
number of arguments has changed</difference>

This difference is due to fixes applied for bug 835113. The old method signature cannot be added back because it would re-introduce the problem fixed by bug 835113. 

This method is just protected so it is not visible (or available for use) outside of inheriting classes. Also, this method is just an override for a base method from ManagedComponentComponent. The base class, ManagedComponentComponent, still has both methods available for use. The fix for bug 835113 had the Ejb2BeanComponent override a different base method. 


Based on this, no action to be taken for this difference.

--- Additional comment from snegrea@redhat.com on 2012-08-17 12:16:02 EDT ---

<difference binseverity="ERROR" srcseverity="ERROR" 
class="org.rhq.plugins.jbossas5.helper.CreateChildResourceFacetDelegate" 
method="public CreateChildResourceFacetDelegate(org.rhq.plugins.jbossas5.ProfileServiceComponent)">In method 'public CreateChildResourceFacetDelegate(org.rhq.plugins.jbossas5.ProfileServiceComponent)' the number of arguments has changed</difference>

Added back the old constructor and marked it as deprecated. The old constructor is not used by RHQ code. If external plugins make use of this constructor, the only downside is the SHA256 computation for exploded content. The SHA256 will not be calculated based on the unexploded content but rather on the exploded files on disk. And this calculation will be done by the content discovery process rather than the deployment process (done in normal circumstances).
Comment 1 Stefan Negrea 2012-08-17 12:22:57 EDT
<difference binseverity="ERROR" srcseverity="ERROR" 
class="org.rhq.plugins.jbossas5.helper.CreateChildResourceFacetDelegate" 
method="public CreateChildResourceFacetDelegate(org.rhq.plugins.jbossas5.ProfileServiceComponent)">In method 'public CreateChildResourceFacetDelegate(org.rhq.plugins.jbossas5.ProfileServiceComponent)' the number of arguments has changed</difference>


release/jon3.1.x branch commit to fix the difference above:

http://git.fedorahosted.org/cgit/rhq/rhq.git/commit/?h=release/jon3.1.x&id=2e4713e24ff482c937eabeefe7eb690461c479a6
Comment 2 John Sanda 2012-08-22 01:46:12 EDT
Moving to ON_QA. The JON 3.1.1 ER3 build is available at https://brewweb.devel.redhat.com/buildinfo?buildID=230321.
Comment 3 Mike Foley 2012-08-31 14:41:40 EDT
verification by soa team testing with jon 3.1.1

Note You need to log in before you can comment on or make changes to this bug.