Bug 849194 - Sound from speakers quits working around 5 minutes after reboot
Sound from speakers quits working around 5 minutes after reboot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: alsa-firmware (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 12:20 EDT by James Perkins
Modified: 2013-02-18 16:16 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-18 15:48:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full boot log to when audio through speakers quits working (208.04 KB, application/octet-stream)
2012-08-17 12:20 EDT, James Perkins
no flags Details
alsa-info.txt (28.91 KB, text/plain)
2012-08-17 12:21 EDT, James Perkins
no flags Details

  None (edit)
Description James Perkins 2012-08-17 12:20:38 EDT
Created attachment 605225 [details]
Full boot log to when audio through speakers quits working

Description of problem:
On my Lenovo ThinkPad T510 after a reboot sound from the speakers works for around 5 minutes, then no sound can be heard. Sound does continue to work through the headphone jack.

This started in Fedora 16. I did a clean install of Fedora 17 hoping the issue would go away, but it did not.

Nothing appears in dmesg when the audio stops working.

In /var/log/messages I do have:

Aug 17 08:21:13 localhost pulseaudio[1680]: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
Aug 17 08:21:13 localhost pulseaudio[1680]: [pulseaudio] module.c: Failed to load module "module-alsa-card" (argument: "device_id="29" name="platform-thinkpad_acpi" card_name="alsa_card.platform-thinkpad_acpi" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes card_properties="module-udev-detect.discovered=1""): initialization failed.


Though I don't think that's the problem as I do get sound for some period of time.

More often than not when the sound stops working there is this message in /var/log/messages right before it quits working.

ug 17 08:24:29 localhost dbus-daemon[824]: dbus[824]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Aug 17 08:24:29 localhost dbus[824]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Aug 17 08:24:29 localhost dbus-daemon[824]: Launching FprintObject
Aug 17 08:24:29 localhost dbus-daemon[824]: dbus[824]: [system] Successfully activated service 'net.reactivated.Fprint'
Aug 17 08:24:29 localhost dbus[824]: [system] Successfully activated service 'net.reactivated.Fprint'
Aug 17 08:24:29 localhost dbus-daemon[824]: ** Message: D-Bus service launched with name: net.reactivated.Fprint
Aug 17 08:24:29 localhost dbus-daemon[824]: ** Message: entering main loop
Aug 17 08:24:59 localhost dbus-daemon[824]: ** Message: No devices in use, exit
Comment 1 James Perkins 2012-08-17 12:21:21 EDT
Created attachment 605226 [details]
alsa-info.txt
Comment 2 sgilda 2012-08-20 09:30:14 EDT
I have had the same problem on my ThinkPad T510 since Fedora 14. I get sound through the speakers for a few minutes, then it stops working. After that, I must rely on headphones or external speakers plugged into the headphone jack for sound.
Comment 3 James Perkins 2012-09-11 15:57:55 EDT
Today I rebooted with my headphones still in the headphone jack. When unplugged the headphones, hours later, the sound did appear to work through the speakers. Again though after roughly 5 minutes there is no sound from the speakers.
Comment 4 James Perkins 2012-09-28 15:42:40 EDT
From this post, http://www.mail-archive.com/alsa-user@lists.sourceforge.net/msg28769.html, executing "hda-verb /dev/snd/hwC0D0 0x1f SET_POWER_STATE 0" does appear to fix it at least temporarily. The sound is lost again after roughly 5 minutes for me.
Comment 5 Tim Jackson 2013-02-18 15:48:01 EST
Sorry but this doesn't sound like a problem with alsa-firmware.
alsa-firmware contains firmware drivers for a very small number of specialist 
sound cards only. Your card is not one of them.

Please be aware that problems with sound can be caused by many different
software components within a Fedora system (including ALSA kernel modules,
PulseAudio, desktop volume controls, individual applications and more) and
you may find it easier to get some informal help to track down the problem 
before filing bugs (if necessary), so that you can file them against the 
right component and the appropriate person can help.

Help resources are listed here:
http://fedoraproject.org/en/get-help

If you still believe that your problem is with alsa-firmware, please re-open this bug with further details. Alternatively, if you identify the software causing the problem, you could change the Component accordingly and re-open it.
Comment 6 James Perkins 2013-02-18 16:16:58 EST
I believe this could be a big in the kernel. At least reading this makes me think it might be, http://www.mail-archive.com/linux-kernel@vger.kernel.org/msg363860.html.

Will the upstream kernel take care of this or should I file a new bug under the kernel. Maybe even kernel-module-thinkpad.

Note You need to log in before you can comment on or make changes to this bug.