Bug 849203 - Fix races in glibc's intl/ testsuite
Fix races in glibc's intl/ testsuite
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jeff Law
qe-baseos-tools
:
Depends On: 849202
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 13:14 EDT by Jeff Law
Modified: 2016-11-24 10:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of: 849202
Environment:
Last Closed: 2013-02-21 02:05:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Law 2012-08-17 13:14:48 EDT
+++ This bug was initially created as a clone of Bug #849202 +++

Description of problem:
There are races in glibc's intl/* tests.  Those races can cause spurious failures in glibc's testsuite which waste engineering & QE's time to analyze.

Version-Release number of selected component (if applicable):


How reproducible:
Run the glibc testsuite with -j<n> for n > 1 repeatedly and watch for failures in tst-gettext3, tst-gettext5 or tst-codeset

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Occasionally one of the above-mentioned tests will fail for no apparent reason.

Expected results:
The tests should pass 100% of the time.

Additional info:
This is strictly a testsuite issue and fixing it is strictly to reduce the amount of wasted time for our engineering staff.  It does not affect the delivered code in any way shape or form.  Multiple approaches to fix the problem are in hand and waiting upstream approval.
Comment 1 Jeff Law 2012-08-17 16:43:33 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 4 errata-xmlrpc 2013-02-21 02:05:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0279.html

Note You need to log in before you can comment on or make changes to this bug.