Bug 849250 - Not setting up a root password makes non-desktop installs impossible to access
Not setting up a root password makes non-desktop installs impossible to access
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On: 848803
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-08-17 15:57 EDT by Adam Williamson
Modified: 2013-01-10 01:53 EST (History)
11 users (show)

See Also:
Fixed In Version: anaconda-18.6.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 12:30:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-08-17 15:57:56 EDT
One of the 'design features' of newUI is that there's no root password step. As I understand it, this was designed this way on the basis that the user should create an 'admin user' during firstboot, a bit Ubuntu-style; I guess the idea is that in general you don't have to use the root account directly, and if you want to do so you can manually set up a root account password with the admin user's privileges.

This is a major change in how the whole distro functions, really, so people may spot other issues with it. But there's one that's clear already: you can't actually rely on firstboot always being run post-install. There are various supported package sets which do not include firstboot. Especially, we don't have a text firstboot any more (and when we did, it didn't actually include account creation), so any non-graphical install will be entirely inaccessible, because it just boots straight to a login tty and you have no account to log in with. You'd have to boot rescue mode or boot a live image and chroot into the installed system, or something, to setup a password for root before you could login directly.

This design needs further thought. The simplest approach, clearly, would be just to go back to requiring the user to set a root password during installation. Given that we're past feature freeze and Alpha freeze, and we're almost certainly going to be drowning in other bugs during the rest of the F18 stabilization cycle, might it be prudent just to go ahead and do that, and save the 'new approach' for F19?
Comment 1 Adam Williamson 2012-08-17 15:59:16 EDT
Proposing as an Alpha blocker: this violates the criterion "When booting a system installed without a graphical environment, or when using a correct configuration setting to cause an installed system to boot in non-graphical mode, the system should boot to a state where it is possible to log in through at least one of the default virtual consoles". You wind up in a state where it is not possible to log in, because there is no account that can possibly be logged into.
Comment 2 Dan Mashal 2012-08-17 22:52:38 EDT
I am able to reproduce this issue.
Comment 3 Adam Williamson 2012-08-20 19:32:06 EDT
Discussed at 2012-08-20 QA meeting, acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2012-08-20/fedora-qa.2012-08-20-15.00.html . Accepted as a blocker per criterion cited in comment #1.
Comment 4 Jesse Keating 2012-08-23 12:14:29 EDT
Current plan is to create an optional root password spoke for graphical installs.  This spoke may not live past F18 alpha, or F18 in general as we look at other long term options.

A patch for the spoke has been posted, but I expect there to be some critique of it and more work before it goes upstream.
Comment 5 Jesse Keating 2012-08-23 16:42:51 EDT
Spoke pushed upstream, will be in the next build of anaconda.
Comment 6 Adam Williamson 2012-08-31 20:09:20 EDT
verified to be present and working in TC4.
Comment 7 Dan Mashal 2012-09-01 02:45:52 EDT
Verified in TC5.
Comment 8 Adam Williamson 2012-09-06 12:30:21 EDT
18.6.5-1 was pushed stable, so closing.
Comment 9 Mateusz Marzantowicz 2012-09-11 09:43:11 EDT
After doing fresh Fedora 18 Alpha installation from CD, I'm unable to manage my Linux system because there is no root account and I haven't added my user to admin group (option is uncheced by defult!!!).

I think this option shoud only be presented to the user on firstboot if there is root account already created. Othervise I have no root and no other account which can run sudo.
Comment 10 Kamil Páral 2012-09-11 10:02:28 EDT
(In reply to comment #9)
Already reported as bug 856194.

Note You need to log in before you can comment on or make changes to this bug.