Bug 84928 - Possible deadlock under heavy load
Possible deadlock under heavy load
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
Depends On:
Blocks: 116726
  Show dependency treegraph
 
Reported: 2003-02-23 18:09 EST by Larry Troan
Modified: 2016-04-18 05:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-19 15:13:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry Troan 2003-02-23 18:09:52 EST
This fix has been accepted in 2.5

http://linux.bkbits.net:8080/linux-2.5/cset@1.1005?nav=index.html|ChangeSet@-1d

cut-n-paste from the checkin message:

We\'re calling mmdrop() under spin_lock_irq(&rq->lock).  But mmdrop
calls vfree(), which calls smp_call_function().

It is not legal to call smp_call_function() with irq\'s off.  Because
another CPU may be running smp_call_function() against _this_ CPU, which
deadlocks.

Our read of the code is that AS 2.1 is also susceptible to this problem.

----------
Action by: arunsharma
Issue Registered

ISSUE TRACKER 16281 by Intel as sev 3
Comment 3 Tim Burke 2004-05-17 11:52:27 EDT
Is a customer really hitting this bug?
Comment 4 Larry Woodman 2004-06-23 10:14:48 EDT
We could never locate the patch thats being referenced here.  Please
provide a link to the actual patch.

Larry

Note You need to log in before you can comment on or make changes to this bug.