Bug 849294 - gluster volume start --xml outputs wrong xml structure
gluster volume start --xml outputs wrong xml structure
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Kaushal
Prasanth
:
Depends On: 845506
Blocks: 858461
  Show dependency treegraph
 
Reported: 2012-08-17 22:08 EDT by Vidya Sakar
Modified: 2013-09-23 18:33 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 845506
: 858461 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:33:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-17 22:08:31 EDT
+++ This bug was initially created as a clone of Bug #845506 +++

gluster volume start --xml outputs

<cliOutput>
  <volStart>
    <flags>0</flags>
    <volname>test1</volname>
  </volStart>
</cliOutput>

expected output is
<cliOutput>
  <opRet>0</opRet>
  <opErrno>0</opErrno>
  <opErrstr/>
  <volStart>
    <volume>
      <name>music</name>
      <id>b3114c71-741b-4c6f-a39e-80384c4ea3cf</id>
      <status>1</status>
    </volume>
  </volStart>
</cliOutput>
Comment 2 Kaushal 2012-10-10 03:22:49 EDT
Patch for upstream/master under review at http://review.gluster.org/3869
Comment 3 Kaushal 2012-10-11 23:51:21 EDT
Fixed by commit f1f3d1c (cli: Changes and enhancements to XML output) for bug https://bugzilla.redhat.com/show_bug.cgi?id=828131 . Reviewed at http://review.gluster.org/3869 .
Comment 4 Prasanth 2013-01-10 03:40:07 EST
Verified in glusterfs-3.4.0qa5-1

Received Output:

# gluster volume start movies --xml 
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput><opRet>0</opRet><opErrno>0</opErrno><opErrstr></opErrstr><volStart><volume><name>movies</name><id>7fa0a317-540d-4e31-be73-377fc4e7338e</id></volume></volStart></cliOutput>
Comment 6 Scott Haines 2013-09-23 18:33:07 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.