Bug 849297 - gluster volume rebalance stop --xml outputs wrong xml structure
gluster volume rebalance stop --xml outputs wrong xml structure
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Kaushal
Prasanth
:
Depends On: 845559
Blocks: 858464
  Show dependency treegraph
 
Reported: 2012-08-17 22:11 EDT by Vidya Sakar
Modified: 2013-09-23 18:33 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 845559
: 858464 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:33:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-17 22:11:14 EDT
+++ This bug was initially created as a clone of Bug #845559 +++

gluster volume rebalance stop --xml outputs 
                                    Node Rebalanced-files          size       scanned      failures         status run time in secs
                               ---------      -----------   -----------   -----------   -----------   ------------    -----------
                               localhost                0            0            0            0      completed           1.00
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput><opRet>0</opRet><opErrno>3</opErrno><opErrstr></opErrstr><cliOp>volRebalance</cliOp><output>Stopped rebalance process on volume test1 
</output></cliOutput>


Expected output is
<cliOutput><opRet>0</opRet><opErrno>3</opErrno><opErrstr></opErrstr><cliOp>volRebalance</cliOp><output>Stopped rebalance process on volume test1 
</output></cliOutput>
Comment 2 Kaushal 2012-10-10 03:22:46 EDT
Patch for upstream/master under review at http://review.gluster.org/3869
Comment 3 Kaushal 2012-10-11 23:51:19 EDT
Fixed by commit f1f3d1c (cli: Changes and enhancements to XML output) for bug https://bugzilla.redhat.com/show_bug.cgi?id=828131 . Reviewed at http://review.gluster.org/3869 .
Comment 7 Prasanth 2013-01-10 06:07:52 EST
Verified in glusterfs-3.4.0qa5-1

# gluster volume rebalance fromclirep stop --xml 
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput><opRet>0</opRet><opErrno>115</opErrno><opErrstr></opErrstr><volRebalance><op>2</op><nodeCount>2</nodeCount><node><nodeName>localhost</nodeName><files>49</files><size>0</size><lookups>149</lookups><failures>0</failures><status>3</status></node><node><nodeName>10.70.36.55</nodeName><files>0</files><size>0</size><lookups>0</lookups><failures>0</failures><status>3</status></node><aggregate><files>49</files><size>0</size><lookups>149</lookups><failures>0</failures></aggregate></volRebalance></cliOutput>
Comment 9 Scott Haines 2013-09-23 18:33:07 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.