Bug 849299 - Proper xml output for "gluster peer status --xml"
Proper xml output for "gluster peer status --xml"
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Kaushal
Prasanth
:
Depends On: 847760
Blocks: 858466
  Show dependency treegraph
 
Reported: 2012-08-17 22:11 EDT by Vidya Sakar
Modified: 2013-09-23 18:33 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 847760
: 858466 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:33:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-17 22:11:30 EDT
+++ This bug was initially created as a clone of Bug #847760 +++

Right now just a generic dict xml output is done. Need proper xml document for peer status.
Comment 2 Prasanth 2013-01-08 06:54:37 EST
Tested in glusterfs-3.4.0qa5-1 and following is the output I see:

----------
# gluster peer status --xml
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput><opRet>0</opRet><opErrno>0</opErrno><opErrstr></opErrstr><peerStatus><peer><uuid>5e34b18d-9b1a-4511-b3f7-28dbbbe87f3d</uuid><hostname>10.70.36.55</hostname><connected>1</connected><state>3</state><stateStr>Peer in Cluster</stateStr><port>24007</port></peer></peerStatus></cliOutput>
----------

Is this the expected output?
Comment 3 Kaushal 2013-01-10 07:05:44 EST
(In reply to comment #2)
> Tested in glusterfs-3.4.0qa5-1 and following is the output I see:
> 
> ----------
> # gluster peer status --xml
> <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
> <cliOutput><opRet>0</opRet><opErrno>0</opErrno><opErrstr></
> opErrstr><peerStatus><peer><uuid>5e34b18d-9b1a-4511-b3f7-28dbbbe87f3d</
> uuid><hostname>10.70.36.55</hostname><connected>1</connected><state>3</
> state><stateStr>Peer in
> Cluster</stateStr><port>24007</port></peer></peerStatus></cliOutput>
> ----------
> 
> Is this the expected output?

This is the expected output.
Comment 4 Prasanth 2013-01-10 07:21:25 EST
Verified in glusterfs-3.4.0qa5-1
Comment 6 Scott Haines 2013-09-23 18:33:07 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.