Bug 849339 - BCM2033 Bluetooth firmware missing
BCM2033 Bluetooth firmware missing
Status: CLOSED DUPLICATE of bug 258681
Product: Fedora
Classification: Fedora
Component: linux-firmware (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-18 10:10 EDT by Frank Büttner
Modified: 2012-08-20 09:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-20 09:54:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Frank Büttner 2012-08-18 10:10:05 EDT
Description of problem:
The firmware for the bcm2033 bluetooth device is missing.

Version-Release number of selected component (if applicable):
linux-firmware-20120720-0.1.git7560108.fc17.noarch

How reproducible:
Every time.


Steps to Reproduce:
1. Plug in the USB device.
  
Actual results:
The kernel will try to load the bcm203x module, but it fails, because the firmware files BCM2033-FW.bin and BCM2033-MD.hex are missing.


Expected results:
working device.


Additional info:
The firmware will be in this file:
http://bluez.sf.net/download/bluez-firmware-1.2.tar.gz

Kernel message:
Aug 18 16:06:56 bart kernel: [24660.991726] bcm203x: probe of 2-1.8.3:1.0 failed with error -5
Comment 1 Josh Boyer 2012-08-20 09:54:45 EDT
The linux-firmware package only ships firmware contained in the upstream linux-firmware git repository (or firmware heading there very soon).  That firmware isn't included upstream.

There was a review for the bluez-firmware package originally and it was found the licensing of the firmware is not compatible with Fedora's firmware rules.  Unfortunately, we cannot provide that.

*** This bug has been marked as a duplicate of bug 258681 ***

Note You need to log in before you can comment on or make changes to this bug.