Bug 849395 - UnicodeDecodeError: 'utf8' codec can't decode byte 0xb8 in position 0: invalid start byte
UnicodeDecodeError: 'utf8' codec can't decode byte 0xb8 in position 0: invali...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
abrt_hash:62a15980e046ad5c385ae20901d...
:
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-08-19 01:08 EDT by Kevin Fenzi
Modified: 2012-09-06 12:21 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-18.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 12:21:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: program.log (16.98 KB, text/plain)
2012-08-19 01:08 EDT, Kevin Fenzi
no flags Details

  None (edit)
Description Kevin Fenzi 2012-08-19 01:08:16 EDT
Description of problem:


Version-Release number of selected component:
anaconda-18.6

Additional info:
libreport version: 2.0.12
cmdline:        initrd=initrd.img  quiet rd.live.check xdriver=vesa BOOT_IMAGE=vmlinuz 
kernel:         3.6.0-0.rc1.git6.1.fc18.x86_64
Comment 1 Kevin Fenzi 2012-08-19 01:08:19 EDT
Created attachment 605456 [details]
File: program.log
Comment 2 Kevin Fenzi 2012-08-19 01:18:42 EDT
This seems to be related to ipv6 support?

Here's the traceback, which it doesn't seem to have attached: 

The following was filed automatically by anaconda:
anaconda 18.6 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 639, in <genexpr>
    ipv6_addr = socket.inet_ntop(socket.AF_INET6, "".join(str(byte) for byte in addr))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 639, in _refresh_device_cfg
    ipv6_addr = socket.inet_ntop(socket.AF_INET6, "".join(str(byte) for byte in addr))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 587, in refresh_ui
    self._refresh_device_cfg((device, num_of_tries))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 362, in on_device_selection_changed
    self.refresh_ui(device)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xb8 in position 0: invalid start byte
Comment 3 Chris Lumens 2012-08-20 11:21:20 EDT
What steps did you take to get this traceback?  Did you enable ipv6 on the command line?
Comment 4 Kevin Fenzi 2012-08-20 11:24:51 EDT
This is a kvm guest with bridged networking. The network is dual stack, and has radvd running to assign ipv6 addresses. The only thing passed on the command line was the 'xdriver=vesa' to get a working graphical install in virt-viewer. 

The instance did have a valid/active ipv6 address... as well as a ipv4 one. I just couldn't continue the install due to this error/issue.
Comment 5 Radek Vykydal 2012-08-21 06:28:12 EDT
Patch sent for review.

You can check the fix with updates image by adding
updates=http://rvykydal.fedorapeople.org/updates.ipv6.img
Comment 6 Radek Vykydal 2012-08-21 06:30:09 EDT
 
> You can check the fix with updates image by adding
> updates=http://rvykydal.fedorapeople.org/updates.ipv6.img

to boot options
Comment 7 Kevin Fenzi 2012-08-21 13:41:23 EDT
I can confirm that this fixes the issue I was seeing. ;) 

Thanks!
Comment 8 Adam Williamson 2012-08-21 14:35:48 EDT
Proposing as Alpha blocker; since F17 we've considered IPv6 to be 'supported functionality' so far as networking goes. So this would violate any criterion requiring networking - e.g. "The installer must be able to use at least one of the HTTP or FTP remote package source options" - in the case of IPv6.

This is a bit different from previous bugs, admittedly, in that we're now talking IPv6 connectivity *within anaconda* - for F17, we focused on bugs which prevented you from easily obtaining IPv6 connectivity in an *installed system*.
Comment 9 Adam Williamson 2012-08-22 13:15:49 EDT
Discussed at 2012-08-22 blocker review meeting. Accepted as a blocker per criterion "The installer must be able to use at least one of the HTTP or FTP remote package source options", in the case of IPv6 addressing - it seems anaconda crashes as soon as it tries to bring up networking, for an IPv6/radvd connection.
Comment 10 Fedora Update System 2012-08-22 18:58:30 EDT
anaconda-18.6.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.6.1-1.fc18
Comment 11 Fedora Update System 2012-08-23 00:36:03 EDT
Package anaconda-18.6.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.6.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12550/anaconda-18.6.1-1.fc18
then log in and leave karma (feedback).
Comment 12 Kamil Páral 2012-08-23 10:35:03 EDT
I can consistently trigger this problem on a bare-metal machine with no cmdline tinkering. We have IPv6 connectivity in our office.

The updates.img from comment #5 fixes the issue.
Comment 13 Kamil Páral 2012-09-04 04:45:16 EDT
I can confirm no traceback occurs with F18 Alpha TC5 (using the same machine).
Comment 14 Adam Williamson 2012-09-06 12:21:14 EDT
18.6.5-1 was pushed stable, so closing.

Note You need to log in before you can comment on or make changes to this bug.