Bug 849430 - Support for one-wire bus missing from kernel
Support for one-wire bus missing from kernel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-19 08:51 EDT by Ian Dall
Modified: 2012-08-23 11:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-23 11:13:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Dall 2012-08-19 08:51:24 EDT
Description of problem:
Support for the one wire bus (W1) and devices is missing from recent kernels.

Version-Release number of selected component (if applicable):

kernel-3.5.0-2.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1.modprobe wire
2.
3.
  
Actual results:
FATAL: Module wire not found.

Expected results:
wire module is loaded

Additional info:

The kernel modules wire and w1_* do not exist because the kernel has not been configured for it.

-bash-4.2# grep W1 /lib/modules/3.5.0-2.fc17.x86_64/source/.config 
# CONFIG_W1 is not set

In 3.1.6-1.fc16 it was configured, but in 3.4.4-4.fc16 it was missing. I appreciate that some choice has to be made about what to include and what not, but it is a bit unfriendly to have things stop working when you do a yum update.
Comment 1 Dave Jones 2012-08-20 12:01:59 EDT
this got culled in the "surely no-one is using this" clean-up back in January.
There were a few false-positives in that list, which we've reenabled and/or moved to kernel-modules-extra.  Given you're the only person to ask for this since then, I suspect we'll move it there too.

Out of curiosity, what are you using this for ?
Comment 2 Ian Dall 2012-08-21 08:52:23 EDT
Kernel-modules-extra would be OK.

Instrumentation. I use the w1_therm. It's about the cheapest way to impliment a whole heap of temperature sensors. The usb to 1-wire interfaces are pretty cheap as well. The bus can be quite long - I forget the maximum length, but I can reliably run a bus to every room in the house for HVAC monitoring.

There are a variety of other chips as well: http://www.maxim-ic.com/products/1-wire-and-ibutton.mvp
Comment 3 Dave Jones 2012-08-21 09:59:59 EDT
neat. I've re-enabled all the modules, and moved them to the extras package.
They'll be in the next build (which should be done today).
Comment 4 Ian Dall 2012-08-23 10:56:10 EDT
Thanks, all is working again!

Note You need to log in before you can comment on or make changes to this bug.