Bug 84944 - Laptop - Lost ability to switch to/from LCD and Monitor
Laptop - Lost ability to switch to/from LCD and Monitor
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-24 02:57 EST by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 16:27:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config from Sony Vaio FXA36 laptop (3.06 KB, text/plain)
2003-02-25 01:13 EST, Warren Togami
no flags Details
XFree86.0.log from Sony Vaio FXA36 (38.73 KB, text/plain)
2003-02-25 01:14 EST, Warren Togami
no flags Details
XFree86-4.2.99.902-20030220.1 log for Packard Bell Chrom@ (ATI RAGE Mobility M1) (37.40 KB, text/plain)
2003-02-25 04:01 EST, Felipe Alfaro Solana
no flags Details
XF86Config for Packard Bell Chrom@ (ATI RAGE Mobility M1) (3.80 KB, text/plain)
2003-02-25 04:04 EST, Felipe Alfaro Solana
no flags Details

  None (edit)
Description Warren Togami 2003-02-24 02:57:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030215

Description of problem:
https://listman.redhat.com/pipermail/phoebe-list/2003-February/003431.html

In Red Hat 8.0 and previous versions of Red Hat Linux my laptop was able to
switch between built-in LCD screen and external monitor with Fn-F7 key.

In Phoebe2 and Phoebe3 I noticed that I completely lost this ability.  If I
change to a text console it works, but the running XFree86  session must be
completely killed in order to change from LCD to monitor or vice versa.

My laptop is a Sony Vaio FXA36, mobile Athlon with VIA KT133a chipset.
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=51325&action=view
More hardware information.

Two other people on phoebe-list have said that their laptop in Phoebe can no
longer switch video output.

Warren Togami
warren@togami.com

Version-Release number of selected component (if applicable):
XFree86-4.2.99.902-20030218.0

How reproducible:
Always
Comment 1 Mike A. Harris 2003-02-24 04:46:50 EST
It's probably a good idea to report this to xfree86@xfree86.org as well,
since I don't have any laptop hardware, it would be very difficult for me
to investigate this matter personally.  I will keep an eye peeled for
bugfixes however, and provide test packages to try if a patch becomes
available.

You might want to attach your config file and log file in case they come
in handy.

Thanks.
Comment 2 Warren Togami 2003-02-25 01:13:48 EST
Created attachment 90339 [details]
XF86Config from Sony Vaio FXA36 laptop
Comment 3 Warren Togami 2003-02-25 01:14:41 EST
Created attachment 90340 [details]
XFree86.0.log from Sony Vaio FXA36
Comment 4 Felipe Alfaro Solana 2003-02-25 04:01:07 EST
Created attachment 90342 [details]
XFree86-4.2.99.902-20030220.1 log for Packard Bell Chrom@ (ATI RAGE Mobility M1)

I'm unable to switch between LCD and external monitor on my computer. Video
output is always displayed simulatenously on both the built-in LCD panel and
the external monitor.
Pressing Fn+F3 to switch output causes a little flash but video output still
goes to both devices.
Comment 5 Felipe Alfaro Solana 2003-02-25 04:04:03 EST
Created attachment 90343 [details]
XF86Config for Packard Bell Chrom@ (ATI RAGE Mobility M1)

NOTE: I have disabled XFS support for X11 but the reported problem is
reproducible with standard XFS-based font support and current config.
Comment 6 Mike A. Harris 2003-02-25 04:08:59 EST
Date: Tue, 25 Feb 2003 02:31:55 -0500 (EST)
From: Leif Delgass <ldelgass@retinalburn.net>
To: xfree86@xfree86.org
Reply-To: xfree86@xfree86.org
Content-Type: TEXT/PLAIN; charset=US-ASCII
Subject: Re: Laptop - Lost ability to switch between LCD and Monitor
 
I think it's more of a feature than a bug. ;)  Based on your X log in the
bugzilla bug, your laptop has a Rage Mobility mach64 chip.  Display
switching via the BIOS (with the X server's VT active) was disabled for
mach64s with dual-CRTCs in XFree86 4.2.99.1:
 
http://cvsweb.xfree86.org/cvsweb/xc/programs/Xserver/hw/xfree86/drivers/ati/atil
ock.c.diff?r1=1.14&r2=1.15&f=h
 
(#105 in the CHANGELOG)
 
My guess is that allowing BIOS-initiated display switches with the X
server active could cause problems because the driver's cached register
state might not be valid after the display switch.  For example, if you
switch from the LCD to the CRT, the driver would continue to program the
card as if the LCD were still active, when in fact the BIOS has changed
the card's state out from under the driver.
 
In the revision above, the feature bit for display switching is re-enabled
when switching away to a text console VT (assuming it was enabled in the
BIOS at server startup), which is why the display switching works there,
but the driver disables the feature bit and restores its cached state when
switching back to the X server.
 
--Leif
Comment 7 Warren Togami 2003-02-25 04:49:35 EST
felipe_alfaro@msn.com said:
> Pressing Fn+F3 to switch output causes a little flash but video output 
> still goes to both devices.

My laptop is Fn+F7, but I too have this screen flash when it attempts to switch
video output and fails.

ldelgass@retinalburn.net said:
> I think it's more of a feature than a bug. ;)  Based on your X log in the
> bugzilla bug, your laptop has a Rage Mobility mach64 chip.  Display
> switching via the BIOS (with the X server's VT active) was disabled for
> mach64s with dual-CRTCs in XFree86 4.2.99.1:

Does this mean we forever lost this ability?  It seemed to work in previous
releases without crashing, though based upon that description I can see
potential for problems...
Comment 8 Mike A. Harris 2003-02-25 05:35:12 EST
I'm inclined to leave the decision up to the ATI driver maintainer
personally.  I suppose there might be a better solution, but I'm not
inclined to look for one without having any of this hardware to work
with.  The ATI driver maintainer or ATI themselves IMHO make the call
here.

I'll leave this open for now to see what creeps up though.
Comment 9 Kevin E. Martin 2004-09-24 16:27:09 EDT
Unfortunately, this has always been a problem with hotkey switching
interacting with the saved register state.  There are no easy
solutions to this problem since it is BIOS specific.  There are a few
laptops that correctly save and restore all state, but most do not.

I would suggest that you file this bug in the X.Org bugzilla
(http://bugs.freedesktop.org using the xorg component), if it still
doesn't work with the current release so that it can be tracked. 
Fixing the problem in a generic way will require involvement of
several components working together, which would be need to be
coordinated with X.Org.

Note You need to log in before you can comment on or make changes to this bug.