Bug 849461 - Using virtio-console causes hard guest lockup
Using virtio-console causes hard guest lockup
Status: CLOSED DUPLICATE of bug 839156
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-19 12:14 EDT by Enrico Scholz
Modified: 2012-08-22 00:42 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 00:42:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2012-08-19 12:14:08 EDT
Description of problem:

Having a guest with

    <console type='pty'>
      <target type='virtio' port='0'/>
    </console>

causes the guest to hang when /dev/hvc0 is accessed (e.g. when console is
started by '/sbin/mingetty /dev/hvc0'). E.g. when console is accessed,
spice/vnc video does not respond anymore and guest can not be reached
over network either.

Things work fine when

    <type arch='x86_64' machine='rhel6.0.0'>hvm</type>

is specified; rhel6.1.0 machine type and above cause the seen lockup.

I am using a RHEL6.3 guest on a RHEL6.3 host.


Guest is started by

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin QEMU_AUDIO_DRV=none /usr/libexec/qemu-kvm -S -M rhel6.3.0 -enable-kvm -m 2048 -smp 2,sockets=2,cores=1,threads=1 -name upnor -uuid 8650828c-2927-62eb-8295-181b0dd7f8bc -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/upnor.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x4 -drive file=/dev/vg00/virt-upnor,if=none,id=drive-virtio-disk0,format=raw,cache=none -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -drive file=/dev/vg00/virt-upnor-cache,if=none,id=drive-virtio-disk1,format=raw,cache=none -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x6,drive=drive-virtio-disk1,id=virtio-disk1 -drive file=/dev/vg00/virt-upnor-data,if=none,id=drive-virtio-disk2,format=raw,cache=none -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio-disk2,id=virtio-disk2 -netdev tap,fd=23,id=hostnet0,vhost=on,vhostfd=25 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=54:52:00:50:08:05,bus=pci.0,addr=0x3 -chardev pty,id=charconsole0 -device virtconsole,chardev=charconsole0,id=console0 -vnc 127.0.0.1:3105 -k en-us -vga cirrus -device i6300esb,id=watchdog0,bus=pci.0,addr=0x9 -watchdog-action reset -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x8
char device redirected to /dev/pts/2


Guest system has

| ACTIVE_CONSOLES="$ACTIVE_CONSOLES /dev/hvc0"

in /etc/sysconfig/init to autostart console.



Version-Release number of selected component (if applicable):

kernel-2.6.32-279.5.1.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6_3.1.x86_64



How reproducible:

100%
Comment 2 Amit Shah 2012-08-20 02:49:46 EDT
Most likely a dup of bug 839156
Comment 3 Amit Shah 2012-08-20 02:50:28 EDT
Can you use a different chardev backend, like unix or tcp, to confirm if it's a dup of the earlier bug?
Comment 4 Enrico Scholz 2012-08-21 13:27:35 EDT
I can not reproduce it with

    <console type='unix'>
      <source mode='bind' path='/tmp/foo'/>
      <target type='virtio' port='0'/>
    </console>

(but 'virsh console' does not work with this setting).
Comment 5 Amit Shah 2012-08-22 00:42:37 EDT
(In reply to comment #4)
> I can not reproduce it with
> 
>     <console type='unix'>
>       <source mode='bind' path='/tmp/foo'/>
>       <target type='virtio' port='0'/>
>     </console>

Thanks for confirming; I'm marking this as a dup of the other bug.

> (but 'virsh console' does not work with this setting).

Not sure why this happens, need to confirm with libvirt developers.

*** This bug has been marked as a duplicate of bug 839156 ***

Note You need to log in before you can comment on or make changes to this bug.