Bug 849482 - AttributeError: 'DeviceFormat' object has no attribute 'mount'
AttributeError: 'DeviceFormat' object has no attribute 'mount'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-19 17:26 EDT by Reartes Guillermo
Modified: 2012-09-17 20:58 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-18.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 18:59:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the error (66.97 KB, image/png)
2012-08-19 17:26 EDT, Reartes Guillermo
no flags Details
requested anaconda logfile (230.23 KB, text/plain)
2012-08-20 12:07 EDT, Reartes Guillermo
no flags Details
another kvm guest example (218.57 KB, text/plain)
2012-08-20 13:00 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-08-19 17:26:56 EDT
Created attachment 605545 [details]
screenshot of the error

Description of problem:

Selecting an ISO file in INSTALLATION SOURCE generates "unknown error" if INSTALLATION DESTINATION step was performed before.

Version-Release number of selected component (if applicable):
F18 TC3 ISO

How reproducible:
always

Steps to Reproduce:
1. boot (basic graphics, due to other issue)
2. goto INSTALLATION DESTINATION and select one disk, auto partition,
and go back to main screen.
3. goto INSTALLATION SOURCE, select ISO File and "Choose an ISO"
4. "unknown error...".
  
Actual results:
error, must reboot the guest.

Expected results:
a dialog for finding iso.

Additional info:
normally (without doing #2. first) the "Choose an ISO" works.
Comment 1 Chris Lumens 2012-08-19 22:18:49 EDT
Please attach /tmp/anaconda-tb-* to this bug report.
Comment 2 Reartes Guillermo 2012-08-20 12:07:36 EDT
Created attachment 605729 [details]
requested anaconda logfile
Comment 3 Reartes Guillermo 2012-08-20 13:00:40 EDT
Created attachment 605743 [details]
another kvm guest example
Comment 4 Fedora Update System 2012-08-22 18:58:41 EDT
anaconda-18.6.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.6.1-1.fc18
Comment 5 Fedora Update System 2012-08-23 00:36:14 EDT
Package anaconda-18.6.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.6.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12550/anaconda-18.6.1-1.fc18
then log in and leave karma (feedback).
Comment 6 Adam Williamson 2012-09-17 18:59:47 EDT
I can't reproduce this with Alpha final (RC3), and 18.6.7 went stable. Closing.
Comment 7 Reartes Guillermo 2012-09-17 19:29:06 EDT
I also cannot reproduce it with rc3 (anaconda 18.6.8), because
the feature was removed.

Installation Source: "ISO file" cannot be found. 
So it was chopped. (or maybe delayed for f19?)
Comment 8 Adam Williamson 2012-09-17 20:58:26 EDT
It's actually smarter than that, I found out after chatting with the devs. the 'installation source' spoke will only show the ISO file option if it's viable. If the planned partition layout set in 'installation destination' involves reformatting all partitions that could possibly contain an ISO file to install from, the 'installation source' spoke won't show the ISO file option. that's probably what you're seeing, if you're going to 'installation source' after selecting the only drive on the system as the target in 'installation destination'.

Note You need to log in before you can comment on or make changes to this bug.