Bug 849484 - Dedicated Touchpad Scrolling Area No Longer Works
Dedicated Touchpad Scrolling Area No Longer Works
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-19 18:24 EDT by J
Modified: 2012-10-21 08:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 17:31:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J 2012-08-19 18:24:37 EDT
Description of problem: Edge scrolling appears to be picked up by the touchpad approximately 10 mm away from the actual right hand side edge. Attempts to move it further right using synclient priduce a narrower and narrower strip until completely unresponsive. The area on the right hand side of my touchpad is marked as a scroll area. This seems to be related to the removal of the feature Option "SpecialScrollAreaRight" "boolean". So I can activate scrolling but it appears to be active approximately 3/4 to the right of my pad surface and the designated area appears to be unresponsive.


Version-Release number of selected component (if applicable):
Name        : xorg-x11-drv-synaptics
Arch        : x86_64
Version     : 1.6.2
Release     : 1.fc17
Size        : 125 k

Name        : kernel
Arch        : x86_64
Version     : 3.5.2
Release     : 1.fc17


How reproducible:
Since update it is the default behaviour

Steps to Reproduce:
1. Go to system settings mouse and touchpad
2. Select touchpad tab and enable edge vertical scrolling
  
Actual results:
Edge scrolling works but is found to start and finished 3/4 of the surface of the touchpad. With the actual right edge being completely dead.

Expected results:
Area marked on touchpad for scrolling - right hand edge - to be the actual area scrolling is picked up from.


Additional info:

synclient -l:
Parameter settings:
    LeftEdge                = 1752
    RightEdge               = 5192
    TopEdge                 = 1620
    BottomEdge              = 4236
    FingerLow               = 25
    FingerHigh              = 30
    FingerPress             = 256
    MaxTapTime              = 180
    MaxTapMove              = 221
    MaxDoubleTapTime        = 180
    SingleTapTimeout        = 180
    ClickTime               = 100
    FastTaps                = 0
    EmulateMidButtonTime    = 75
    EmulateTwoFingerMinZ    = 28
    EmulateTwoFingerMinW    = 7
    VertScrollDelta         = 100
    HorizScrollDelta        = 100
    VertEdgeScroll          = 1
    HorizEdgeScroll         = 0
    CornerCoasting          = 0
    VertTwoFingerScroll     = 0
    HorizTwoFingerScroll    = 0
    MinSpeed                = 1
    MaxSpeed                = 1.75
    AccelFactor             = 0.0398089
    TrackstickSpeed         = 40
    EdgeMotionMinZ          = 30
    EdgeMotionMaxZ          = 160
    EdgeMotionMinSpeed      = 1
    EdgeMotionMaxSpeed      = 401
    EdgeMotionUseAlways     = 0
    TouchpadOff             = 0
    LockedDrags             = 0
    LockedDragTimeout       = 5000
    RTCornerButton          = 0
    RBCornerButton          = 0
    LTCornerButton          = 0
    LBCornerButton          = 0
    TapButton1              = 1
    TapButton2              = 0
    TapButton3              = 0
    ClickFinger1            = 1
    ClickFinger2            = 1
    ClickFinger3            = 1
    CircularScrolling       = 0
    CircScrollDelta         = 0.1
    CircScrollTrigger       = 0
    CircularPad             = 0
    PalmDetect              = 0
    PalmMinWidth            = 10
    PalmMinZ                = 200
    CoastingSpeed           = 20
    CoastingFriction        = 50
    PressureMotionMinZ      = 30
    PressureMotionMaxZ      = 160
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
    GrabEventDevice         = 1
    TapAndDragGesture       = 1
    AreaLeftEdge            = 0
    AreaRightEdge           = 0
    AreaTopEdge             = 0
    AreaBottomEdge          = 0
    HorizHysteresis         = 25
    VertHysteresis          = 25
    ClickPad                = 0

From Xorg.0.log:
[    40.067] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event5)
[    40.067] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    40.067] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    40.067] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[    40.067] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "tap-by-default"
[    40.067] (II) LoadModule: "synaptics"
[    40.067] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[    40.080] (II) Module synaptics: vendor="X.Org Foundation"
[    40.080] 	compiled for 1.12.0, module version = 1.6.2
[    40.080] 	Module class: X.Org XInput Driver
[    40.080] 	ABI class: X.Org XInput driver, version 16.0
[    40.080] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[    40.080] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    40.080] (**) Option "Device" "/dev/input/event5"
[    40.112] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472
[    40.112] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448
[    40.112] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    40.112] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[    40.112] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right double triple
[    40.112] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[    40.112] (**) Option "TapButton1" "1"
[    40.112] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    40.112] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    40.128] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input5/event5"
[    40.128] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 12)
[    40.128] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    40.128] (**) synaptics: SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[    40.128] (**) synaptics: SynPS/2 Synaptics TouchPad: AccelFactor is now 0.040
[    40.128] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    40.128] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    40.128] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    40.128] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    40.128] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    40.128] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[    40.128] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "tap-by-default"
[    40.128] (II) No input driver specified, ignoring this device.
[    40.128] (II) This device may have been added with another device file.

xorg.conf:
Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

xorg.conf.d:
Section "InputClass"
       Identifier "tap-by-default"
       MatchIsTouchpad "on"
       Option "TapButton1" "1"
EndSection
Comment 1 Borut Semenic 2012-08-24 03:54:55 EDT
Can confirm same problem here.
Comment 2 J 2012-08-24 04:14:46 EDT
Problem persists with the recent kernel and Xorg updates as well.

Name        : kernel
Arch        : x86_64
Version     : 3.5.2
Release     : 3.fc17

Name        : xorg-x11-server-Xorg
Arch        : x86_64
Version     : 1.12.3
Release     : 1.fc17
Comment 3 Borut Semenic 2012-09-24 04:19:32 EDT
Problem persists with the recent kernel,Xorg and all other updates.

kernel 3.5.4-1.fc17.x86_64 
xorg-x11-server-Xorg-1.12.3-2.fc17.x86_64.
Comment 4 Borut Semenic 2012-10-11 13:11:18 EDT
Problem is fixed for me.

kernel-3.6.1-1.fc17.x86_64

Thank you.
Comment 5 Peter Hutterer 2012-10-11 19:08:49 EDT
J, can you confirm this fixes the issue for you too?
Comment 6 J 2012-10-15 11:40:29 EDT
Hi Peter

Sorry for the delay I did not have access to the machine. I can confirm that vertical scrolling using the dedicated scrolling area on my touchpad now works again.

Thanks for all your effort for sorting this.
Comment 7 J 2012-10-15 11:41:09 EDT
3.6.1-1.fc17.x86_64 as well.
Comment 8 Peter Hutterer 2012-10-15 17:31:15 EDT
thanks for letting us know, closing as WORKSFORME
Comment 9 Sunta 2012-10-16 11:05:57 EDT
(In reply to comment #8)
> thanks for letting us know, closing as WORKSFORME

I think this probably needs to be reopened or something, I don't know if Borut Semenic and J can confirm this too?

Unfortunately at least in my case, this bug is not completely fixed with kernel 3.6.x, just partly. 

Now, edge scrolling area is expanded to the right where it should be, but it's expanded, not shifted back to the right edge, like it's supposed to be, so now active scrolling area is twice as wide as it was, about 20mm wide now instead of about 10mm.

So the problem is kind of, half fixed. ;)
Comment 10 J 2012-10-21 08:32:50 EDT
I can confirm I see the same as Sunta but didn't notice at first due to my chubby little fingers!

Yes it is working but yes it is about 1.5 cm wide in total may be more when including the dedicated touch area. Its 100% better than no dedicated area though.

Note You need to log in before you can comment on or make changes to this bug.