Bug 849487 - Unable to add Python plugins
Unable to add Python plugins
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
17
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Huzaifa S. Sidhpurwala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-19 18:52 EDT by Richard P
Modified: 2012-09-30 14:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 19:27:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard P 2012-08-19 18:52:33 EDT
Description of problem:
The ability to add Python plugins to gnumeric is missing.

Version-Release number of selected component (if applicable):
Was available in build 1.11.3-1; missing in 1.11.5-1

How reproducible:
Every time.

Steps to Reproduce:
1. Add Python plugin as documented in /usr/share/gnome/help/gnumeric/C/extending-python.xml
2. Launch gnumeric
3. Click "Insert", "Function"
  
Actual results:
No new function(s) appear in list

Expected results:
Your new Python based function(s) appear in list

Additional info:
This functionality silently drops out due to missing 'BuildRequires: pygobject3-devel' in spec file.
Comment 1 Julian Sikorski 2012-08-20 14:11:30 EDT
I'll add this in the next release. Any ideas why it used to work before?
Comment 2 Richard P 2012-08-20 16:42:42 EDT
My best guess is that 1.11.3-1 built on a system, that just by coincidence, already had pygobject3-devel installed. When 1.11.5-1 built, I suspect we were not so lucky...

I noticed that I failed to report I am running the x86_64 version: gnumeric-1.11.5-1.fc17.x86_64.rpm. I confirmed that gnumeric-1.11.5-1.fc17.i686.rpm is missing the same support.

FYI: When gnumeric-1.11.3-1.fc17.x86_64.rpm built, pygobject3-devel being installed allowed the rpm to include the following files, providing the missing support:

/usr/lib64/gnumeric/1.11.3/plugins/py-func/plugin.xml
/usr/lib64/gnumeric/1.11.3/plugins/py-func/py_func.py
/usr/lib64/gnumeric/1.11.3/plugins/py-func/py_func.pyc
/usr/lib64/gnumeric/1.11.3/plugins/py-func/py_func.pyo
/usr/lib64/gnumeric/1.11.3/plugins/python-loader/plugin.xml
/usr/lib64/gnumeric/1.11.3/plugins/python-loader/python_loader.so
/usr/lib64/gnumeric/1.11.3/plugins/python-loader/ui-console-menu.xml

Thanks
Comment 3 Fedora Update System 2012-09-10 15:58:32 EDT
goffice-0.9.6-1.fc18,gnumeric-1.11.6-2.fc18,gnome-chemistry-utils-0.13.92-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/goffice-0.9.6-1.fc18,gnumeric-1.11.6-2.fc18,gnome-chemistry-utils-0.13.92-1.fc18
Comment 4 Julian Sikorski 2012-09-10 15:59:54 EDT
F-17 is pending on the libgsf update.
Comment 5 Fedora Update System 2012-09-11 15:12:48 EDT
Package goffice-0.9.6-1.fc18, gnumeric-1.11.6-2.fc18, gnome-chemistry-utils-0.13.92-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing goffice-0.9.6-1.fc18 gnumeric-1.11.6-2.fc18 gnome-chemistry-utils-0.13.92-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13818/goffice-0.9.6-1.fc18,gnumeric-1.11.6-2.fc18,gnome-chemistry-utils-0.13.92-1.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-09-17 19:27:31 EDT
goffice-0.9.6-1.fc18, gnumeric-1.11.6-2.fc18, gnome-chemistry-utils-0.13.92-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-09-30 14:16:34 EDT
gnumeric-1.11.5-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gnumeric-1.11.5-2.fc17

Note You need to log in before you can comment on or make changes to this bug.