Bug 849490 - php-fpm package is missing from fedora-arm
php-fpm package is missing from fedora-arm
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
17
arm Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-19 19:29 EDT by Russ
Modified: 2012-09-19 08:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-04 18:59:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russ 2012-08-19 19:29:00 EDT
Description of problem:
php-fpm package is missing from fedora-arm

Version-Release number of selected component (if applicable):
php-fpm 5.4.5-1.fc17

How reproducible:
always

Steps to Reproduce:
1. yum install php-fpm

  
Actual results:
No package php-fpm available

Expected results:
Install  1 Package


Additional info:
This is one of a few reasons why fedora-arm is STILL basically a useless ARM distro for most people. Php-fpm is an ESSENTIAL package if you want to run a decent "LEMP" server on an ARM platform. Debian and Ubuntu have had php-fpm for WAY over a year, at minimum. I know that because I've been using php-fpm on Debian that long on my ARM server. Unfortunately, I still don't have the option of using Fedora due to missing package issues such as this. Fedora is actually the superior ARM distro in many respects. But this, and the lack of ATrpms, still prevents me from using it on our ARM servers. FCGI works, but is outdated.
Comment 1 Remi Collet 2012-08-20 01:59:19 EDT
Currently running a test build on fedora secondary arch (ppc64 and arm)
Comment 2 Remi Collet 2012-08-20 02:21:13 EDT
ppc64 successful scratch build.
http://koji.fedoraproject.org/koji/taskinfo?taskID=4404963
Comment 3 Remi Collet 2012-08-20 06:54:14 EDT
armv7hl successful scratch build:
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1081197

armv5tel successful scratch build:
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1081198
Comment 4 Fedora Update System 2012-08-20 07:35:19 EDT
php-5.4.6-2.fc18, maniadrive-1.2-45.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-12108/php-5.4.6-2.fc18,maniadrive-1.2-45.fc18
Comment 5 Fedora Update System 2012-08-20 07:52:41 EDT
php-5.4.6-2.fc17, maniadrive-1.2-45.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-12162/php-5.4.6-2.fc17,maniadrive-1.2-45.fc17
Comment 6 Russ 2012-08-20 09:10:50 EDT
(In reply to comment #3)
> armv7hl successful scratch build:
> http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1081197
> 
> armv5tel successful scratch build:
> http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1081198

Thanks Remi!

This pkg is really needed, as otherwise it's a major show-stopper on ARM. One of the best uses of the ARM platform is as a low-power-usage Web server. But you need Nginx and php-fpm to be able to take advantage of it.

Looking forward to it. F17 otherwise outperforms Debian for most ARM httpd usage.
Comment 7 Fedora Update System 2012-08-20 15:51:37 EDT
Package php-5.4.6-2.fc18, maniadrive-1.2-45.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing php-5.4.6-2.fc18 maniadrive-1.2-45.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12108/php-5.4.6-2.fc18,maniadrive-1.2-45.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-09-04 18:59:22 EDT
php-5.4.6-2.fc17, maniadrive-1.2-45.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-09-17 19:40:16 EDT
php-5.4.6-2.fc18, maniadrive-1.2-45.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Russ 2012-09-19 08:37:50 EDT
Somebody really needs to fix the Fedora Update System messages to remove the maniadrive crap. Maniadrive has nothing at all to do with this bug.

Note You need to log in before you can comment on or make changes to this bug.