Bug 849539 - Allocating tags to different projects doesn't influence search results
Allocating tags to different projects doesn't influence search results
Status: CLOSED NOTABUG
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 03:08 EDT by Dana Mison
Modified: 2013-02-04 00:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-04 00:20:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dana Mison 2012-08-20 03:08:35 EDT
Tags can be allocated to projects.  This doesn't seem to do anything except separate them into different tabs on the search screen.  It doesn't appear to affect the search results.


Expected behaviour:
When searching, if I select a tag from only one of the project tabs that it appears under: I expect that only the topics tagged with that tag from the project  will get matched by the search.

Actual behaviour:
The search matches all the topics with that tag regardless of the project.
Comment 1 Lee Newson 2012-08-20 04:38:08 EDT
A project isn't mapped to any topics therefore this isn't possible atm. Projects are really just a grouping of tags that make it more user friendly. To do this I imagine you would need to have a "Project" category tag type of setup.

Anyways that's the reason it doesn't work, but I'll leave it for Matt to comment/have a look and then work from there.
Comment 2 Dana Mison 2012-08-20 22:53:05 EDT
Re: conversation in meeting

1. The way this works should be considered correct for this version and documented as such to avoid potential confusion (create a doc bug for this?)

2. The way this works should be made more intuitive in the new UI

3. Should this bug become an RFE for 2.x ?
Comment 3 Matthew Casperson 2013-02-04 00:20:42 EST
This is the expected behaviour. This is a training/documentation issue.

Note You need to log in before you can comment on or make changes to this bug.