Bug 849544 - [Hyper-V pv drivers]Two mouse icons show up on the guest screen
[Hyper-V pv drivers]Two mouse icons show up on the guest screen
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.9
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Vitaly Kuznetsov
Virtualization Bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 03:22 EDT by Shengnan Wang
Modified: 2015-05-15 08:51 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-15 08:51:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Two mouse icons show up on the guest screen (210.49 KB, image/jpeg)
2012-08-20 03:24 EDT, Shengnan Wang
no flags Details

  None (edit)
Description Shengnan Wang 2012-08-20 03:22:45 EDT
Description of problem:

Visit the RHEL guest VM via the Hyper-V Manager installed on the physical machine. There are two mouse icons on the guest screen. one is a dot, and the other is a arrow. When moving the mouse, both of them will move. Only the mouse with arrow is valid for using. It's not very convenient for the customer using.


Version-Release number of selected component (if applicable):
Host: Windows 2008 R2 Hyper-V (6.1.7600.16385)
Guest: RHEL5.9 guest (2.6.18-336.el5)
Pv drivers: 
# lsmod |grep hv_*
hid_base_hv            68177  1 hid_hyperv
hv_netvsc              25665  0 
hv_utils               12001  0 
hv_storvsc             17601  3 
hv_vmbus               30265  4 hid_hyperv,hv_netvsc,hv_utils,hv_storvsc

How reproducible:
100%

Steps to Reproduce:
1.Login a guest with graphical output via Hyper-V Manager which is installed on the physical machine. 
2.Move the mouse and use it to do some operations.


Actual results:

At step2, there are two icons on the guest screen and the two icons don't track each other well.

Expected results:

At step2, there is one icons or the two icons track each other well.


Additional info:
1. Test the mouse with the windows guest on Hyper-V host. Two icons track each other well.
2. There is one mouse icon on the guest RHEL5.9 Server-base (2.6.18-333.el5) without the hyper-v pv drivers. The mouse works well on the guest screen, although the mouse icon is bound into the virtual machine. Use "Ctrl + Alt + left" to unbound it.
Comment 1 Shengnan Wang 2012-08-20 03:24:29 EDT
Created attachment 605591 [details]
Two mouse icons show up on the guest screen
Comment 2 Ronen Hod 2012-08-30 05:55:45 EDT
Closing following
https://bugzilla.redhat.com/show_bug.cgi?id=824877#c97
Comment 3 Shengnan Wang 2012-10-18 06:26:58 EDT
Visit the RHEL5.9 guest(2.6.18-343.el5) via the Hyper-V Manager installed on the physical machine. The same issue occurred. However, visit the RHEL5.9 guest (2.6.18-343.el5) via vncviewer, the issue doesn't occur. There is only one mouse.
Comment 4 Shengnan Wang 2012-10-24 02:43:44 EDT
CC K.Y.
The middle wheel of the mouse isn't available, when visit the RHEL5.9 guest(2.6.18-343.el5) via the Hyper-V Manager installed on the physical machine. Is the reason the same with the two mouse icons issue? Details, please have a look at comment 139 in bug 824877. https://bugzilla.redhat.com/show_bug.cgi?id=824877#c139
Comment 5 K. Y. Srinivasan 2012-10-24 09:45:21 EDT
I posted this issue to the Hyper-V guys and have not heard back yet. I will continue to ping them on this. I suspect having two mouse icons is not related to this.
Comment 11 Ronen Hod 2014-09-21 03:17:37 EDT
K.Y.,

We are getting requests to fix this RHEL5 bug. How does it look?
Comment 12 K. Y. Srinivasan 2014-09-21 10:25:58 EDT
We need to port the frame buffer driver to RHEL5 to fix this issue.
Comment 13 RHEL Product and Program Management 2014-09-24 10:43:34 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 14 Vitaly Kuznetsov 2015-05-15 08:51:41 EDT
As stated in https://bugzilla.redhat.com/show_bug.cgi?id=849544#c12 we need to  backport the frame buffer driver to fix the issue. RHEL5 is in Production 3 phase which means it's too late for such a change. Closing the bug as 'WONTFIX' for now.

Note You need to log in before you can comment on or make changes to this bug.