Bug 849563 - GTK UI seems to be broken sometimes
GTK UI seems to be broken sometimes
Status: CLOSED DUPLICATE of bug 849211
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-08-20 04:26 EDT by Jan Sedlák
Modified: 2012-08-24 09:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-08-24 09:50:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
INSTALLATION SOURCE remains greyed out (55.77 KB, image/png)
2012-08-20 04:26 EDT, Jan Sedlák
no flags Details
software selection is broken (17.13 KB, image/png)
2012-08-20 04:27 EDT, Jan Sedlák
no flags Details
dialogs are displaced (40.43 KB, image/png)
2012-08-20 04:28 EDT, Jan Sedlák
no flags Details
installation destination dialog is too displaced (31.43 KB, image/png)
2012-08-20 04:29 EDT, Jan Sedlák
no flags Details
gziped logs (42.83 KB, application/x-gzip)
2012-08-22 04:54 EDT, Jan Sedlák
no flags Details
second gziped logs (43.22 KB, application/x-gzip)
2012-08-22 05:24 EDT, Jan Sedlák
no flags Details

  None (edit)
Description Jan Sedlák 2012-08-20 04:26:15 EDT
Created attachment 605597 [details]
INSTALLATION SOURCE remains greyed out

Description of problem:
From time to time, after I boot anaconda installer, button "INSTALLATION SOURCE" remains greyed out (see screenshot in first attachment) even when it initializes. Since then, UI seems to be broken - see screenshots in attachments.

How reproducible:
From time to time (badly reproducible)

Steps to Reproduce:
1. Have a bad luck
2. Boot TC3 installer

Actual results:
"INSTALLATION SOURCE" remains greyed out. UI is broken.

Expected results:
Working UI

Additional info:
It happens in cca. 25% of cases, mostly three to five times in a row (it happens again after reboot).
Comment 1 Jan Sedlák 2012-08-20 04:27:09 EDT
Created attachment 605598 [details]
software selection is broken
Comment 2 Jan Sedlák 2012-08-20 04:28:24 EDT
Created attachment 605599 [details]
dialogs are displaced
Comment 3 Jan Sedlák 2012-08-20 04:29:21 EDT
Created attachment 605600 [details]
installation destination dialog is too displaced
Comment 4 Jan Sedlák 2012-08-20 05:10:40 EDT
I think that it happens when "Downloading package metadata" takes too long (it's displayed under both, "installation source" and "software selection").
Comment 5 Chris Lumens 2012-08-20 11:40:04 EDT
There are several problems here all in the same bug report, which makes it difficult to track any one thing.

How long something takes is not going to be the problem, because we're waiting for threads to finish before updating the UI.  We're not just blindly waiting a certain amount of time.

Your screen shot in comment #1 is probably related to comps/yum/anaconda changes that have not all shown up in the same tree at the same time.

I don't know why your screens are shrunk down like that, but I've seen it from a few other people too.  I cannot reproduce it so I can't work on it.
Comment 6 Chris Lumens 2012-08-20 15:55:36 EDT
Yeah okay, I am seeing all these problems now too.  When the source spoke claims it's ready (but is still greyed out), can you click on a spoke and then check your X.log and see if it looks like the bottom of mine:   http://clumens.fedorapeople.org/X.log
Comment 7 Jan Sedlák 2012-08-21 06:37:30 EDT
Sorry, but no. Bottom of X.log looks normal, with:
[    24.086] (**) ImExPS/2 Generic Explorer Mouse: (accel) keeping acceleration scheme 1
[    24.087] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration profile 0
[    24.087] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration factor: 2.000
[    24.087] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration threshold: 4
[    24.087] (II) VMWARE(0): VMMOUSE DEVICE_ON
[    24.087] (II) VMWARE(0): vmmouse enabled
[    24.088] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/mouse0)
[    24.088] (II) No input driver specified, ignoring this device.
[    24.088] (II) This device may have been added with another device file.
Comment 8 Chris Lumens 2012-08-21 13:28:17 EDT
When you hit this problem, can you please grab /tmp/anaconda.log and /tmp/syslog and attach them to this bug report?  I am only intermittently able to reproduce this bug, and other people I've had check are not having a lot of luck with it either.  Thanks.
Comment 9 Jan Sedlák 2012-08-22 04:40:51 EDT
I've gziped whole /tmp directory (except of tmux-0/, yum.cache/ and yum.root/). For me, it's hard to reproduce it reliably too. Best chance is to "start installation as quickly as possible" (as soon as the "Choose language" appears, click on "continue"), but you have to try it several times.
Comment 10 Jan Sedlák 2012-08-22 04:54:12 EDT
Created attachment 606176 [details]
gziped logs
Comment 11 Jan Sedlák 2012-08-22 05:23:56 EDT
I've also attached log from successful instalator startup. Only difference I see is different order of modprobe/mount at the end of program.log and additional "WARN" and "DEBUG" at the end of storage.log in unsuccessful instalator startup log.
Comment 12 Jan Sedlák 2012-08-22 05:24:21 EDT
Created attachment 606183 [details]
second gziped logs
Comment 13 Chris Lumens 2012-08-24 09:50:48 EDT

*** This bug has been marked as a duplicate of bug 849211 ***

Note You need to log in before you can comment on or make changes to this bug.