Bug 849607 - dpms setting not sticking
dpms setting not sticking
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: upower (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 06:35 EDT by Hin-Tak Leung
Modified: 2013-07-03 22:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-03 22:01:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hin-Tak Leung 2012-08-20 06:35:49 EDT
Description of problem:
I have always had my computer set to blank screen after 10 minutes. This is still being shown as 10 minutes when I do 'user name' (top right corner) -> system settings -> brightness and lock.

But underneath, running 'xset q':

soon after log in, it shows: 

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600

DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On

But then the timeout and cycle changes to zero; and the screen never goes to sleep.

I leave a mount of applications running all the time but expect my screen to switch off after a while. this is not working in the last few week.

I tried 'xset dpms 10 10 10', or 60 60 60, or have the screensaver blanking right away and it does turn off, but then it wakes up again after a while on its own, untouched; and I would find the values reset to zero again. same with the screensaver values.

Version-Release number of selected component (if applicable):
upower-0.9.17-1.fc17.x86_64

How reproducible:
always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
screen does not blank on its own.

Expected results:
screen goes blank after 10 minutes of inactivity.

Additional info:
I have not changed how I use my computer at all; this problem is new in the last few week. The closest I can think of is upowerd, but it may be another party - please feel free to re-assign. The system is in gnome 3.4 fallback mode.

I cannot figure out what component is periodically overwriting the screensaver/dpms values to zero.  I have tried setting them to 10, 60, 600 - 600 being 10 minutes as I have configured in the GUI - but the setting don't last - e.g. screen blank then wake  up by itself after a while, or screensaver blank then unblank and xset q keep showing those values being reset to zero after a while.

As I say, this problem is ony a few weeks old. I keep my system up to date f17.
Comment 1 Fedora End Of Life 2013-07-03 18:42:48 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 2 Hin-Tak Leung 2013-07-03 22:01:02 EDT
Don't remember it being a problem towards end of f18. Will file new bug if f19 doesn't sleep.

Note You need to log in before you can comment on or make changes to this bug.