Bug 849629 - Select host operation in Datacenter guide me invokes ChangeVDSCluster with no action
Select host operation in Datacenter guide me invokes ChangeVDSCluster with no...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Alexey Chub
Pavel Stehlik
infra
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 07:46 EDT by Tomas Dosek
Modified: 2016-02-10 14:14 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 10:50:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Dosek 2012-08-20 07:46:15 EDT
Description of problem:

Select host operation in Datacenter guide me invokes ChangeVDSCluster with no action

Version-Release number of selected component (if applicable):
si14

How reproducible:
100 %

Steps to Reproduce:
1. Have a host in maintenance mode (already was a part of some other dc/cluster)
2. Create new DC using guide me dialogue, add cluster, choose select host (in my case the dc type was local)
3. Click on ok button
  
Actual results:
Host isn't moved to the new dc/cluster

Expected results:
Host should be moved to the new dc/cluster

Additional info:
Log:
2012-08-20 13:42:59,785 INFO  [org.ovirt.engine.core.bll.MultipleActionsRunner] (ajp-/127.0.0.1:8009-13) MultipleActionsRunner of type ChangeVDSCluster invoked with no actions
Comment 2 Einav Cohen 2012-08-23 07:24:52 EDT
Tomas:

regarding step 2 ("choose select host"): Once you opened the Hosts selection dialog, did it contain any items? If so, did you select any items before clicking on ok (step 3)?

[If there weren't any items, this could be related/duplicate of bug 728276 (flagged for rhevm_future)]
Comment 3 Tomas Dosek 2012-08-23 07:27:11 EDT
The select host list contained the maintenanced host and I selected it before clicking on OK button.
Comment 4 Einav Cohen 2012-08-23 07:34:40 EDT
Thanks Tomas.

It means that it is not related to bug 728276.

might be a GUI bug (that doesn't sent the correct parameters to RunMultipleActions) or a backend bug (that doesn't handle the RunMultipleActions command correctly).
Comment 5 Alexey Chub 2012-09-02 07:59:28 EDT
Doesn't happen anymore (works for me).

I saw another action "...[org.ovirt.engine.core.bll.MultipleActionsRunner]...invoked with no actions" in my logs.

After taking latest version such kind of message doesn't appear anymore.
Probably was fixed in backend.

Note You need to log in before you can comment on or make changes to this bug.