Bug 849667 - Bugreporting from anaconda doesn't work as expected
Bugreporting from anaconda doesn't work as expected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-meh (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-08-20 09:57 EDT by Vratislav Podzimek
Modified: 2012-08-27 21:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-27 21:57:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vratislav Podzimek 2012-08-20 09:57:20 EDT
Description of problem:
Bug reporting of Anaconda's unhandled exceptions doesn't work as expected. Reporting bug fails if there is some empty item in the bug info overview (bug in libreport) and the attached anaconda-tb file does not contain the anaconda object dump because of the exception appearing during the dump (python-meh bug).

I am proposing this as a F18Alpha blocker according to this criteria:
>"The installer must be able to report failures to Bugzilla and local disk, with appropriate information included."

Version-Release number of selected component (if applicable):
python-meh-0.14-1.fc18
libreport-2.0.12-2.fc18

How reproducible:
100 %

Steps to Reproduce:
1. use one of the known cases when anaconda raises unhandled exception
2. try to report bug with/without empty items
  
Actual results:
Issues as described above.

Expected results:
No issues.

Additional info:
new libreport build libreport-2.0.12-5.fc18 already available in koji
new python-meh scratch build (patches waiting for a review) available at:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4406262
Comment 1 Fedora Update System 2012-08-20 11:18:13 EDT
python-meh-0.15-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-meh-0.15-1.fc18
Comment 3 Fedora Update System 2012-08-20 15:51:05 EDT
Package python-meh-0.15-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-meh-0.15-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12317/python-meh-0.15-1.fc18
then log in and leave karma (feedback).
Comment 4 Adam Williamson 2012-08-20 19:36:33 EDT
Discussed at 2012-08-20 QA meeting, acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2012-08-20/fedora-qa.2012-08-20-15.00.html . Accepted as a blocker per criterion "The installer must be able to report failures to Bugzilla and local disk, with appropriate information included" (this bug clearly affects the 'appropriate information' part at least).
Comment 5 Fedora Update System 2012-08-27 21:57:35 EDT
python-meh-0.15-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.