This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 849683 - Drop web services
Drop web services
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Web Services (Show other bugs)
JON 3.1.0
All All
high Severity high
: ER01
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On: 849681
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 11:03 EDT by Heiko W. Rupp
Modified: 2014-01-02 15:34 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 849681
Environment:
Last Closed: 2014-01-02 15:34:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2012-08-20 11:03:23 EDT
+++ This bug was initially created as a clone of Bug #849681 +++

Webserices are not used and are a pain in the build.
Comment 1 Heiko W. Rupp 2012-08-20 11:04:09 EDT
Web services are marked as deprecated in jon3.1(.1), so they can be removed in jon 3.2
Comment 2 John Mazzitelli 2013-05-02 11:36:56 EDT
If this BZ is asking to remove the RHQ webservices module from the build, that was already done in RHQ 4.6 release.

I'm setting this to MODIFIED since our webservices stuff was already ripped out of the upstream.

Note that we did not (AFAIK) take out the underlying webservices container service that ships with AS7/EAP. That is a separate issue (I don't know if we have a BZ for that, but we should have a task to remove unused services from the underlying app server).
Comment 3 Larry O'Leary 2013-09-06 10:31:22 EDT
As this is MODIFIED or ON_QA, setting milestone to ER1.

Note You need to log in before you can comment on or make changes to this bug.