Bug 849767 - Under load thin servers crash
Under load thin servers crash
Status: CLOSED WONTFIX
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity high
: beta
: 1.2
Assigned To: Jordan OMara
SAM QE List
: Triaged
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-08-20 15:33 EDT by Eric Sammons
Modified: 2014-11-09 17:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 14:51:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sammons 2012-08-20 15:33:35 EDT
Description of problem:
When testing against a well loaded sam-1.1 system it is possible to get the thin servers to fail and crash.

~2000 systems
> 60 orgs, each with no less than 4 environments
> 15 roles
> 50 users

4G of RAM
2xVCPU

Version-Release number of selected component (if applicable):
katello-cli-common-0.3.5-2.el6_2.noarch
katello-headpin-all-0.2.13-1.el6_2.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-glue-candlepin-0.3.3-1.el6_2.noarch
katello-cli-headpin-0.2.2-1.el6_2.noarch
katello-configure-0.3.7-1.el6_2.noarch
katello-headpin-0.2.13-1.el6_2.noarch
katello-selinux-0.2.4-1.el6_2.noarch
katello-common-0.3.3-1.el6_2.noarch
katello-certs-tools-1.1.5-1.el6_2.noarch

+ Performance Hotfix


Steps to Reproduce:
Against a loaded system (well loaded) run multiple, varying types of tests; best to use automation to drive the tests to ensure differing interactions with the environment.

  
Actual results:
thin server will crash without warning, HTTPS requests return Service Temporarily Unavailable.

ps -ef|grep thin returns no pids

service katello stop returns; /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/daemonizing.rb:140:in `kill': No such process (Errno::ESRCH)

Expected results:
System should remain operational
Comment 1 Jordan OMara 2012-10-23 14:51:14 EDT
Can't reproduce. Will be performance tested soon so if it is still a bug in 1.2 it should resurface

Note You need to log in before you can comment on or make changes to this bug.