Bug 849770 - Probing the first host won't update the hostname on the second host
Probing the first host won't update the hostname on the second host
Status: CLOSED DEFERRED
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
3.3.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Kaushal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 15:36 EDT by Daniel Banck
Modified: 2014-12-14 14:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-14 14:40:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Banck 2012-08-20 15:36:17 EDT
Description of problem:
I've got two servers running Ubuntu 12.04 with glusterFS 3.3.0 (from this deb: http://download.gluster.org/pub/gluster/glusterfs/LATEST/Ubuntu/12.04/glusterfs_3.3.0-1_amd64.deb)
Probing the second server on the first one will add a peer on both servers (as expected)

Output after this:
root@hv04 ~ # gluster peer status
Number of Peers: 1

Hostname: hv03-gluster
Uuid: 53073441-49b1-49d5-9805-a0280a9fe667
State: Peer in Cluster (Connected)
---
root@hv03 ~ # gluster peer status
Number of Peers: 1

Hostname: 2a01:4f8:163:7401::2
Uuid: 006c961b-edf4-4e47-a0ff-de40c08992ab
State: Peer in Cluster (Connected)


Probing the first server from the second should update the hostname. But it doesn't change anything.

  
Actual results:
root@hv04 ~ # gluster peer status
Number of Peers: 1

Hostname: hv03-gluster
Uuid: 53073441-49b1-49d5-9805-a0280a9fe667
State: Peer in Cluster (Connected)
---
root@hv03 ~ # gluster peer status
Number of Peers: 1

Hostname: 2a01:4f8:163:7401::2
Uuid: 006c961b-edf4-4e47-a0ff-de40c08992ab
State: Peer in Cluster (Connected)


Expected results:
root@hv04 ~ # gluster peer status
Number of Peers: 1

Hostname: hv03-gluster
Uuid: 53073441-49b1-49d5-9805-a0280a9fe667
State: Peer in Cluster (Connected)
---
root@hv03 ~ # gluster peer status
Number of Peers: 1

Hostname: hv04-gluster
Uuid: 006c961b-edf4-4e47-a0ff-de40c08992ab
State: Peer in Cluster (Connected)
Comment 1 Joe Julian 2012-08-20 15:55:06 EDT
As a workaround, I had him stop both glusterd and update the peer file. This worked as expected.

The problem, of course, is that in an ipv6-only system the address is being interpreted as a hostname. Since there were no volumes using this address/hostname, a peer probe should have changed the hostname. This should be true regarless of whether it's a hostname or an IP address. If the hostname isn't used in a volume, you should be able to change the hostname by probing that host with a different name.
Comment 2 Niels de Vos 2014-11-27 09:53:48 EST
The version that this bug has been reported against, does not get any updates from the Gluster Community anymore. Please verify if this report is still valid against a current (3.4, 3.5 or 3.6) release and update the version, or close this bug.

If there has been no update before 9 December 2014, this bug will get automatocally closed.

Note You need to log in before you can comment on or make changes to this bug.