Bug 849807 - Receive error messages when accessing broker rest api from browser in production
Receive error messages when accessing broker rest api from browser in production
Status: CLOSED WORKSFORME
Product: OpenShift Origin
Classification: Red Hat
Component: Master (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Lili Nader
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 20:57 EDT by Clayton Coleman
Modified: 2015-05-14 20:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 17:29:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Coleman 2012-08-20 20:57:37 EDT
When I try to access /broker/rest/api.json from my browser I see output.  When I try to access any other resources I get a service error page, probably due to an exception or other bad response from the server.  This works in the devenv.

Also happens with 

  curl -k -u <user>:<pass> https://openshift.redhat.com/broker/rest/domains.json

Can be deferred out of this sprint but this would affect anyone using AJAX to hit the server.
Comment 1 Lili Nader 2012-08-20 21:33:57 EDT
It works for me on openshift.redhat.com.  Can you please add a -i option to your curl request so we can see what HTTP response code you are getting and also the server output.
Comment 2 Clayton Coleman 2012-08-20 23:16:55 EDT
No longer happens in curl, still happening in browser.
Comment 3 Ravi Sankar 2012-08-29 17:25:20 EDT
Tried https://openshift.redhat.com/broker/rest/domains.json,../rest/domains/<dom>.json, .../rest/domains/<dom>/applications.json on commandline using curl and also in browser and it worked as expected.
Clayton, can you tell us which rest api is not working in browser? and whats the error message?
Comment 4 Clayton Coleman 2012-08-29 17:29:33 EDT
Looks to no longer happen in browser.  Error message was purely generic (the 5xx apache error page in production), I couldn't see the logs.

I'll close and reopen if it happens again.

Note You need to log in before you can comment on or make changes to this bug.