Bug 849814 - There are some error happened when create app without "app" option
There are some error happened when create app without "app" option
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 21:58 EDT by xjia
Modified: 2015-07-19 20:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-20 22:53:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xjia 2012-08-20 21:58:09 EDT
Description of problem:
When create app without "app" command, it prompts some error.

Version-Release number of selected component (if applicable):
rhc-0.97.12
devenv 2036

How reproducible:
Always

Steps to Reproduce:
1.rhc create -a php1 -t php-5.3 -pjia -s 
  
Actual results:
[jason@jasontest ~]$ rhc create -a php1 -t php-5.3 -pjia -s 
/usr/lib/ruby/gems/1.8/gems/commander-4.1.2/lib/commander/runner.rb:398:in `run_active_command': invalid command (Commander::Runner::InvalidCommandError)
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.97.12/lib/rhc/commands.rb:73:in `run!'
	from /usr/lib/ruby/gems/1.8/gems/commander-4.1.2/lib/commander/delegates.rb:7:in `run!'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.97.12/lib/rhc/cli.rb:37:in `start'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.97.12/bin/rhc:62
	from /usr/bin/rhc:19:in `load'
	from /usr/bin/rhc:19

Expected results:
The command 'rhc create' is not recognized.

Additional info:
Comment 1 xjia 2012-08-20 22:53:00 EDT
I am sorry. I think it may be not a bug. I find the '-t' option.

-t|--trace                Display backtrace when an error occurs

Note You need to log in before you can comment on or make changes to this bug.