Bug 849950 - Cartridges like MongoDB will become the fist cartridge on the application details page sometimes.
Cartridges like MongoDB will become the fist cartridge on the application det...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 06:01 EDT by Yujie Zhang
Modified: 2015-05-14 21:13 EDT (History)
3 users (show)

See Also:
Fixed In Version: devenv_2147
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:29:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot1 (94.08 KB, image/png)
2012-08-21 06:01 EDT, Yujie Zhang
no flags Details
screenshot2 (132.43 KB, image/png)
2012-09-06 01:43 EDT, Yujie Zhang
no flags Details
Diy screen shot (131.56 KB, image/png)
2012-09-10 05:21 EDT, Yujie Zhang
no flags Details
Diy screenshot2 (125.55 KB, image/png)
2012-09-11 07:33 EDT, Yujie Zhang
no flags Details
zend.png (80.23 KB, image/png)
2012-09-13 06:14 EDT, Wei Sun
no flags Details
diy.png (90.32 KB, image/png)
2012-09-13 06:15 EDT, Wei Sun
no flags Details
php app (144.67 KB, image/png)
2012-09-13 23:47 EDT, Yujie Zhang
no flags Details

  None (edit)
Description Yujie Zhang 2012-08-21 06:01:28 EDT
Created attachment 605902 [details]
screenshot1

Description of problem:

I created a zend application and embeded mongoDB and returned to the app details page, found that MongoDB became the fist app cartridge on details page, the first cartridge should be application type on details page. The issue always happens on zend application, and randomly happens on other applications. 

Version-Release number of selected component (if applicable):

INT

How reproducible:randomly


Steps to Reproduce:
1.Go to openshift website and login
2.Create a zend application and embed mongodb  
3.Check the application details page
  
Actual results:

MongoDB became the first cartridge on application details page.Details see in attachment please.

Expected results:

The first cartridge on details page should always be application type.

Additional info:
Comment 1 Clayton Coleman 2012-08-21 09:33:40 EDT
Zend is missing the correct categories in its manifest.  Compare manifest from ruby to manifest to Zend.

Categories:
  - cartridge
  - web_framework

It's also missing license, website, and Cart-Data (assuming there is some).
Comment 2 Lili Nader 2012-08-21 16:03:22 EDT
https://github.com/openshift/li/pull/287
Comment 3 Lili Nader 2012-08-22 13:15:19 EDT
lowering severity since zend is not getting released this sprint
Comment 4 Lili Nader 2012-08-22 18:54:44 EDT
As of build devenv_2054 the manifest.yml is showing the correct categories but the UI is still showing zend-5.6 as the second cartridge and also not showing the Description in the app_types page.

Name: zend-5.6
Display-Name: zend server v5.6.0 (noarch)
Description: "Web Application Server for Business-Critical PHP Applications"
Version: 5.6
License: "Commercial"
License-Url: http://static.zend.com/topics/Zend-License-EULA-2010-09-2.pdf
Vendor:  Zend
Categories:
  - cartridge
  - web_framework
Website: http://www.zend.com
Comment 5 Yujie Zhang 2012-09-06 01:42:18 EDT
(In reply to comment #4)
Tested this issue on devenv_2119 and fork_ami_opensource_console_77, besides zend, it also exists on other applications now, like cakephp, so change the severity so you can take a look at this issue as soon as possible.Details see in attachment.
Comment 6 Yujie Zhang 2012-09-06 01:43:27 EDT
Created attachment 610174 [details]
screenshot2
Comment 7 Xiaoli Tian 2012-09-07 07:31:43 EDT
Remove FutureFeature keyword for this sprint to bring it to your attention, if it's still FutureFeature, feel free to add it back.

Thanks
Comment 8 Clayton Coleman 2012-09-07 14:04:16 EDT
There were bugs in cartridge tag reading in the site.  Looking at backporting.
Comment 9 Clayton Coleman 2012-09-07 15:27:25 EDT
https://github.com/openshift/li/pull/353
Comment 10 Yujie Zhang 2012-09-10 05:17:15 EDT
Tested this issue on devenv_2040, still has this issue when creating diy application, could you please check this issue again?
Comment 11 Yujie Zhang 2012-09-10 05:21:57 EDT
Created attachment 611363 [details]
Diy screen shot
Comment 12 Clayton Coleman 2012-09-10 14:59:41 EDT
https://github.com/openshift/crankcase/pull/466

DIY was "web-framework" instead of "web_framework"
Comment 13 Yujie Zhang 2012-09-11 03:17:46 EDT
(In reply to comment #12)
Will wait for devenv_2147 to test this issue.
Comment 14 Xiaoli Tian 2012-09-11 03:37:25 EDT
devenv_2147 is ready for testing
Comment 15 Yujie Zhang 2012-09-11 07:32:57 EDT
(In reply to comment #9)
Tested this issue on devenv_2149, still has this issue when creating diy application, so assign it back.
Comment 16 Yujie Zhang 2012-09-11 07:33:46 EDT
Created attachment 611735 [details]
Diy screenshot2
Comment 17 John Poelstra 2012-09-11 13:13:18 EDT
expect to complete today
Comment 18 Clayton Coleman 2012-09-11 13:41:49 EDT
Bug in crankcase was hiding deeper bug.

https://github.com/openshift/li/pull/359
Comment 19 Yujie Zhang 2012-09-12 03:41:02 EDT
(In reply to comment #18)
Tested this on INT and devenv_2156 today, this issue also exists after enabling jenkins for applications.
Comment 20 Wei Sun 2012-09-13 06:14:40 EDT
Created attachment 612400 [details]
zend.png

verified on INT(devenv_2168)
Comment 21 Wei Sun 2012-09-13 06:15:25 EDT
Created attachment 612401 [details]
diy.png
Comment 22 Yujie Zhang 2012-09-13 23:46:13 EDT
(In reply to comment #18)
hi Clayton, I tested this issue on stage today, it appeared on php application, seems this issue will randomly happen on different cartridge, so I will change it to a randomly bug and lower the severity in case it block stage.
Comment 23 Yujie Zhang 2012-09-13 23:47:22 EDT
Created attachment 612712 [details]
php app
Comment 24 Clayton Coleman 2012-09-14 13:11:07 EDT
https://github.com/openshift/crankcase/pull/490
Comment 25 Yujie Zhang 2012-09-17 02:19:49 EDT
Tested this issue on devenv-stage_237, tried on all the cartridges, did not meet this issue again, so verify this bug.

Note You need to log in before you can comment on or make changes to this bug.