Bug 849953 - qcow2 + read|reread block performance degrade on 6.3 guest compared to 5.9 guest on 5.9 host
qcow2 + read|reread block performance degrade on 6.3 guest compared to 5.9 gu...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Asias He
Red Hat Kernel QE team
:
: 849944 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 06:08 EDT by Xiaomei Gao
Modified: 2012-09-23 21:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-23 21:39:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
iozone script (383 bytes, application/x-gzip)
2012-09-12 08:51 EDT, Xiaomei Gao
no flags Details

  None (edit)
Comment 2 Xiaomei Gao 2012-09-12 08:45:21 EDT
hi, asias
    
    please check the attachment.

Best Regards

xigao
Comment 3 Xiaomei Gao 2012-09-12 08:51:50 EDT
Created attachment 612088 [details]
iozone script
Comment 4 Asias He 2012-09-23 21:19:47 EDT
*** Bug 849944 has been marked as a duplicate of this bug. ***
Comment 5 Asias He 2012-09-23 21:39:02 EDT
There are three sets of tests that Xiaomei run:
1) with direct io
2) with small file < 0.9 system ram size 
3) with large file > 2.0 system ram size

The 'regression' we can is only in test 2). In this case, we are testing the I/O in ram instead of the real disk I/O. The result is not reliable nor stable. E.g the read speed in test 2) is 4883 MB/s while the read speed in test 1) is 101 MB/s.

This is not a regression, I am closing it.

Note You need to log in before you can comment on or make changes to this bug.