Bug 849990 - Apper: Authentization failed when trying to install updates
Apper: Authentization failed when trying to install updates
Status: CLOSED DUPLICATE of bug 852403
Product: Fedora
Classification: Fedora
Component: polkit (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 08:34 EDT by Martin Krizek
Modified: 2013-03-05 23:08 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 13:29:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot (257.49 KB, image/png)
2012-08-21 08:34 EDT, Martin Krizek
no flags Details

  None (edit)
Description Martin Krizek 2012-08-21 08:34:09 EDT
Created attachment 605926 [details]
screenshot

Description of problem:
Installed Fedora 18 x86_64 with KDE in KVM. I had to chroot to the installation and manually set root password and then create a user. I run Apper and tried to apply updates but got the following error (also attaching screenshot): "You have failed to provide correct authentification. Please check any passwords or account settings.". Note, that I have not been asked for root password. Installation via "yum update" works flawlessly.

Version-Release number of selected component (if applicable):
apper-0.8.0-0.4.20120724git.fc18.x86_64

How reproducible:
Always
Comment 1 Martin Krizek 2012-08-21 08:37:00 EDT
I am proposing this as an Alpha blocker per criterion: "The installed system must be able to download and install updates with yum and the default graphical package manager in all release-blocking desktops.".
Comment 2 Rex Dieter 2012-08-21 11:14:16 EDT
hoping  bug #829881 is the root cause of this, and fixing that helps here.  we'll find out
Comment 3 Rex Dieter 2012-08-21 11:18:22 EDT
looks like bug #841451 is a better candidate.
Comment 4 Kevin Kofler 2012-08-21 11:20:14 EDT
#829881 is not the same issue. We have only one .pkla file and that's for setting the clock.
Comment 5 Adam Williamson 2012-08-21 19:07:27 EDT
+1 blocker, per criterion cited in comment #1.
Comment 6 Adam Williamson 2012-08-21 19:14:28 EDT
rex: I'm not sure it'd be 841451. We currently believe that issue affects only yum updates from f17 to f18. on a fresh install, polkit appears to work correctly. we're not 100% sure of it yet, but that's my current belief. martin, can you verify whether polkit is running and the polkitd user is correctly created?
Comment 7 Martin Krizek 2012-08-22 08:09:15 EDT
Sure, polkit is running, the polkitd user is created as following:
polkitd:x:999:999:User for polkitd:/:/sbin/nologin
Comment 8 Adam Williamson 2012-08-22 13:19:51 EDT
Discussed at 2012-08-22 blocker review meeting. Accepted as a blocker per criterion "The installed system must be able to download and install updates with yum and the default graphical package manager in all release-blocking desktops", for the KDE desktop. We don't believe this is a case of #841451, as per comment #7 - polkit is running correctly, but Apper isn't talking to it somehow.
Comment 9 Martin Kho 2012-08-23 03:37:19 EDT
Hi,

FWIW, Yesterday updating my distro-sync'd fc18 - upgraded from fc17 - with Apper - apper-0.8.0-0.4.20120724git.fc18.x86_64 - went without a problem. 

1) With respect to comment #2: bug #829881 seems indeed not to be the cause. /var/lib/polkit-1/localauthority/10-vendor.d/ still contains 11-fedora-kde-policy.pkla.

2) Polkit is active - /usr/lib/polkit-1/polkitd --no-debug
and  /usr/libexec/kde4/polkit-kde-authentication-agent-1

So it looks to me more an installation / configuration issue. Missing dependencies or changed configuration Fedora specific not KDE?


Hope this helps,

Martin Kho

BTW: User - me - is in the wheel - sudoers - group and I run selinux in permissive mode.
Comment 10 Jaroslav Reznik 2012-08-29 11:18:42 EDT
Seems like a change in Polkit 0.107 behaviour - I don't see a request in log. Reassigning to polkit-kde.
Comment 11 Jaroslav Reznik 2012-08-29 12:01:52 EDT
Well, it seems even with Gnome Auth Agent I'm unable to authenificate - for both KDE/Gnome agents dialog poups and it's dismissed, authorization fails. Let's try polkit.
Comment 12 Jaroslav Reznik 2012-08-29 12:04:43 EDT
From polkitd - 12:02:28.213: Operator of unix-session:6 FAILED to authenticate to gain authorization for action org.freedesktop.policykit.exec for unix-process:6334:1322118 [/bin/bash] (owned by unix-user:jreznik)
Comment 13 Adam Williamson 2012-08-29 13:29:13 EDT
Turns out this and 852403 are dupes. That one is the cleaner bug, so we're marking this as the dupe and transferring blocker status to that bug.

*** This bug has been marked as a duplicate of bug 852403 ***

Note You need to log in before you can comment on or make changes to this bug.