Bug 8500 - Framebuffer support in 6.2 kernel
Framebuffer support in 6.2 kernel
Status: CLOSED DUPLICATE of bug 8789
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-15 15:02 EST by Bernhard Rosenkraenzer
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-05 02:05:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Rosenkraenzer 2000-01-15 15:02:02 EST
Including framebuffer support in the 6.2 kernel was IMO a very bad idea.
First of all, it causes garbled text mode on some chipsets occasionally (my notebook, using an ATI Rage LT Pro chipset, for example, will occasionally display VERY odd stuff).
Second, it breaks switching between X and console on various chipsets.
Third, you're NEVER supposed to run a normal X server on a kernel with framebuffer support. (See /usr/src/linux/Documentation/fb/vesafb.txt). It'll also very probably break some older graphics cards (did anyone try to boot this kernel with an EGA card?).
Actually, the fact that they did this before was one of the reasons I used to tell people to use Red Hat Linux instead of Caldera OpenLinux.
Please at least turn if OFF by default. (Yes, I know the penguin at bootup looks nice, but it's not enough of a reason to mess up the system).
Comment 1 Bernhard Rosenkraenzer 2000-01-16 06:10:59 EST
Just seen the first really major breakage caused by framebuffers:
On a Gericom 3xC notebook (ATI Rage LT Pro chipset, some Mach64), with
the stock 6.2b1 kernel, you can't start X (unless you use the framebuffer server); it just turns the screen black.
Also, when using "d$" in vi, the line being edited gets garbled.
We really really need to remove fb (at least atyfb, haven't tried the others)
Comment 2 Bill Nottingham 2000-02-05 02:05:59 EST
*** This bug has been marked as a duplicate of 8789 ***

Note You need to log in before you can comment on or make changes to this bug.