Bug 850003 - One machine is crashing when running kernel-PAE-3.6.0-0.rc2.git0.1.fc18.i686 but not kernel-PAE-3.6.0-0.rc1.git0.2.fc18.i686
One machine is crashing when running kernel-PAE-3.6.0-0.rc2.git0.1.fc18.i686 ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F18Alpha-accepted/F18AlphaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-08-21 09:07 EDT by Bruno Wolff III
Modified: 2012-08-23 20:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-23 20:11:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
netconsole output for a crash (1.90 KB, text/plain)
2012-08-22 08:40 EDT, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2012-08-21 09:07:24 EDT
Description of problem:
I have 4 machines that I have tried 3.6.0-0.rc2.git0.1 kernels on, but only one is crashing. The one that is crashing is an athlon MP 2 processor machine, is using rawhide and has an rv280 based video card. The other machines have various intel processors, are using f18 and have various different video cards (not rv280s).

I typically get to a desktop when booting before the system crashes. At this point I haven't done enough tries to get an idea of what is triggering the crashes.
Comment 1 Bruno Wolff III 2012-08-22 08:40:02 EDT
Created attachment 606242 [details]
netconsole output for a crash
Comment 2 Josh Boyer 2012-08-22 09:32:00 EDT
Ignoring the large number of out-of-tree modules, that looks like it should be fixed by commit fae6ef87faeb8853896920c68ee703d715799d28.  That's included in today's rc2-git2.1 build.  You'll have to grab it from koji since we're in Alpha freeze.
Comment 3 Bruno Wolff III 2012-08-22 11:10:20 EDT
I build the dahdi linux drivers from source for each kernel, but can easily exclude them for testing. The dahdi stuff is just being used as an intercom in the house right now so I can go without it for periods of time.

I was planning to try a later build tonight, so I'll give that build a test. I tried last night to use 3.6.0-0.rc2.git1.2, but the initramfs was bad (from systemd probably) and I was too tired to stay up and putz with that, so i just left 3.6.0-0.rc2.git0.1 up with netconsole set up.
Comment 4 Fedora Update System 2012-08-22 12:06:35 EDT
kernel-3.6.0-0.rc2.git2.1.fc18, grub2-2.00-5.fc18, pesign-0.10-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.0-0.rc2.git2.1.fc18,grub2-2.00-5.fc18,pesign-0.10-4.fc18
Comment 5 Adam Williamson 2012-08-22 13:36:31 EDT
Nominating as an Alpha NTH. Showstopper crashes on boot are bad.
Comment 6 Adam Williamson 2012-08-22 14:02:38 EDT
Discussed at 2012-08-22 NTH review meeting. Accepted as NTH since we definitely want to avoid showstopper kernel crashes.
Comment 7 Bruno Wolff III 2012-08-22 16:15:18 EDT
Typically I was actually getting the machine booted. It did seem to normally crash within a few minutes if I was using it. That could still be problematic for an alpha though.

I also may have see this crash on a second machine with a lot different hardware, but don't know if it was the same problem or even kernel related as I had just updated some gnome stuff and started having issues with that after the reboot.
Comment 8 Josh Boyer 2012-08-22 16:44:31 EDT
(In reply to comment #7)
> Typically I was actually getting the machine booted. It did seem to normally
> crash within a few minutes if I was using it. That could still be
> problematic for an alpha though.
> 
> I also may have see this crash on a second machine with a lot different
> hardware, but don't know if it was the same problem or even kernel related
> as I had just updated some gnome stuff and started having issues with that
> after the reboot.

All of that relates to what kernel version?  The one you originally reported against, or the one submitted for the update?
Comment 9 Bruno Wolff III 2012-08-22 16:57:46 EDT
3.6.0-0.rc2.git0.1 still. The first was about the original bug. The second was on an x86_64 machine, but otherwise the same kernel version. It just hadn't crashed earlier. I am not sure why my one machine seemed to die fairly quickly.  I am now running 3.6.0-0.rc2.git2.1 on the x86_64 machine and will switch a couple of other machines over at home tonight. (I can't reboot them remotely as I need to enter passwords.)
I'll leave netconsole setup at home for a while so that I can get useful info if the machine crashes again.
Comment 10 Bruno Wolff III 2012-08-23 08:36:00 EDT
I tested 3.6.0-0.rc2.git2.1 (since that's the kernel we're thinking of using for alpha) kernels on three machines overnight including the one that was crashing regularly with 3.6.0-0.rc2.git0.1 and didn't see any problems. I am switching to 3.6.0-0.rc3.git0.1 now, since the debug kernels run too slow to use for regular use.
Comment 11 Fedora Update System 2012-08-23 20:11:57 EDT
kernel-3.6.0-0.rc2.git2.1.fc18, grub2-2.00-5.fc18, pesign-0.10-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.