Bug 850040 - Introduce new systemd-rpm macros in autofs spec file
Introduce new systemd-rpm macros in autofs spec file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
18
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 850016
  Show dependency treegraph
 
Reported: 2012-08-21 09:26 EDT by Lukáš Nykrýn
Modified: 2012-09-17 19:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: autofs-5.0.7-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 19:11:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukáš Nykrýn 2012-08-21 09:26:10 EDT
Fedora 18 changes the way how to work with services in spec files. It introduces new macros - %systemd_post, %systemd_preun and %systemd_postun; which replace scriptlets from Fedora 17 and older (see https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd, https://bugzilla.redhat.com/show_bug.cgi?id=850016).
Comment 1 Ian Kent 2012-08-27 06:04:14 EDT
So what should be done in this case in %post, since autofs is
permitted to be enable by default?

AFAICS the predefined macro doesn't do this.
Comment 2 Václav Pavlín 2012-08-27 06:58:23 EDT
Thank's for the information. Simply use the %systemd_post, autofs will be added to the presets as enabled.
Comment 3 Fedora Update System 2012-08-27 07:24:59 EDT
autofs-5.0.7-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/autofs-5.0.7-2.fc18
Comment 4 Fedora Update System 2012-08-27 12:29:47 EDT
Package autofs-5.0.7-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing autofs-5.0.7-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12752/autofs-5.0.7-2.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-09-17 19:11:04 EDT
autofs-5.0.7-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.