Bug 850056 - include the tests/data directory in the python-test rpm
include the tests/data directory in the python-test rpm
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python (Show other bugs)
7.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Bohuslav "Slavek" Kabrda
Branislav Náter
:
Depends On: 625395
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 09:28 EDT by Branislav Náter
Modified: 2015-09-27 22:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: python-2.7.5-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 625395
Environment:
Last Closed: 2014-06-13 08:26:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Dave Malcolm 2013-02-20 15:53:12 EST
Fix committed to Fedora git "master" for F19 as:
http://pkgs.fedoraproject.org/cgit/python.git/commit/?id=8b819675253e8c45dd1b877d705c1eae2ed9e76b

Building python-2.7.3-24.fc19 for rawhide
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=5037891
Comment 5 Bohuslav "Slavek" Kabrda 2013-08-01 05:35:51 EDT
This has been built for RHEL 7 a while ago, it is fixed in current latest build of python: python-2.7.5-4.el7
Comment 7 Branislav Náter 2013-11-15 09:40:36 EST
Bugfix has been verified on python-2.7.5-10.el7 package. tests/data directory is present in python-test package. Unit tests (/CoreOS/python/Sanity/unit-tests) now runs without issues caused by missing data directory.
Comment 8 Ludek Smid 2014-06-13 08:26:51 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.