Bug 850142 - Introduce new systemd-rpm macros in hail spec file
Introduce new systemd-rpm macros in hail spec file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hail (Show other bugs)
18
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 850016
  Show dependency treegraph
 
Reported: 2012-08-21 09:40 EDT by Lukáš Nykrýn
Modified: 2013-03-19 14:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 14:34:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukáš Nykrýn 2012-08-21 09:40:33 EDT
Fedora 18 changes the way how to work with services in spec files. It introduces new macros - %systemd_post, %systemd_preun and %systemd_postun; which replace scriptlets from Fedora 17 and older (see https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd, https://bugzilla.redhat.com/show_bug.cgi?id=850016).
Comment 1 Pete Zaitcev 2013-01-21 22:16:29 EST
Fixed this in git, committed and pushed as hail-0.8-0.11.gf9c5b967, but
cannot build due to a random conflict in Rawhide (gcc vs libtool).
Comment 2 Pete Zaitcev 2013-03-19 14:34:10 EDT
Hmm, weird. Apparently I did build hail-0.8-0.13.gf9c5b967.fc19 after all.
Anyway, fixed in hail-0.8-0.13.gf9c5b967.fc20, closing.

Note You need to log in before you can comment on or make changes to this bug.