Bug 85017 - RFE installation of MP3 / mpeg support, and RealOne players [after non-GPL acceptance]
RFE installation of MP3 / mpeg support, and RealOne players [after non-GPL ac...
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-media (Show other bugs)
phoebe
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-24 16:56 EST by Elton Woo
Modified: 2015-01-07 19:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-24 19:37:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
WHERE TO dl RealOne player, HOWTO install (2.66 KB, text/plain)
2003-02-24 17:38 EST, Elton Woo
no flags Details

  None (edit)
Description Elton Woo 2003-02-24 16:56:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030215

Description of problem:
During firstboot, popup advised user that MP3 is not included with RED HAT distro
due to licencing issues. IF user accepts licencing terms, redirect to Internet link
(e.g. freshrpms.net to download and install).

In the case of RealOne Player, redirect user to links for download and installation.

(SEE also attachment of my comments on HOWTO and WHERETO, including 
compliance with Plugger)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. During firstboot, advise user or issues WRT mp3 /mpeg support. 
2. Advise of availablity of RealOne Player (Realplayer 9 for linux)
3. User accepts licencing terms and is redirecte to appropriate links.
    

Actual Results:  These are not availiable, notification WRT mp3/mpeg licencing
issues is not
immediataly clear (unfortunately, some users / installers _fail to_ READ the
readmes on DISK 1, or the readmes are _not available_ for perusal, *during*
INITIAL installation of code

Expected Results:  During firstboot, installation of mp3 / mpeg support and
Realaudio/ Real video should be available to user (as su,  ... in the case of
mp3/mpeg codecs).

Additional info:

RFE in the interests of makig the distro more "user-friendly' to new users or those
migrating from other OSes...
Comment 1 Elton Woo 2003-02-24 17:38:52 EST
Created attachment 90329 [details]
WHERE TO dl RealOne player, HOWTO install
Comment 2 Bill Nottingham 2003-02-24 19:37:04 EST
Absolutely not.

A) Pointing people at things that may violate the GPL is dishonest and
potentially illegal.
B) Pointing people at things that may violate patents is potentially illegal.
C) Implicitly authorizing installation of third party software that is not
tested or verified, and could even be potentially trojaned is a very bad
security idea.
Comment 3 Elton Woo 2003-02-25 14:47:43 EST
I guess I did not explain myself in sufficient detail (and I *did* forget to include some important 
comments WRT licencing).  
What I meant was NOT to inentionally thwart copyrights or encourage illegal downloading of 
software. 
 
WRT, the mp3 /mpg codec, my suggestion is to direct the user to a link, *AFTER* he/she has 
read a DISCLAIMER and WARNING that there is / maybe licencing restrictions, and that 
obtaining the code is "AYOR". 
 
As per the RealOne Player, again, only allow the user to download and obtain the code, 
*after* acceptance of and perusal of the licencing / copyright agreement (to wit: something 
to the effect:"... and I agree and confirm that my downloading and usage of this software is 
solely for personal use, under the terms of the GPL and/or RealAudio. 
 
That said, however, I won't pursue this any further, as can understand the mess caused by 
the Mp3/mpg issue. 
 
Would a simple textfile MUST READ readme suffice to warn the user of WHY these codes 
are NOT included, and directing them to "search Google instead" suffice? 
 
As much as one might like ogg to be a widely accepted format. The fact that the dominating 
format *is* mp3 ... unless Red Hat includes a converter  ... with the CAVEAT that the 
conversion severely affects the sound quality? 
 
My intention with this RFE was to make life easer for those migrating to linux, but in 
fact, "easier said than done", alas. 

Note You need to log in before you can comment on or make changes to this bug.