Bug 850206 - Introduce new systemd-rpm macros in mgetty spec file
Introduce new systemd-rpm macros in mgetty spec file
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mgetty (Show other bugs)
18
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michal Sekletar
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 850016
  Show dependency treegraph
 
Reported: 2012-08-21 09:49 EDT by Lukáš Nykrýn
Modified: 2013-07-31 10:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 10:50:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lukáš Nykrýn 2012-08-21 09:49:35 EDT
Fedora 18 changes the way how to work with services in spec files. It introduces new macros - %systemd_post, %systemd_preun and %systemd_postun; which replace scriptlets from Fedora 17 and older (see https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd, https://bugzilla.redhat.com/show_bug.cgi?id=850016).
Comment 1 Michal Sekletar 2013-03-19 11:59:15 EDT
Fixed in f19. Direct impact on user here is very low, not worth of pushing update. Closing as NEXTRELEASE.
Comment 2 mrj 2013-07-10 03:50:25 EDT
This Systemd macro works in Fedora 19. However mgetty started by Systemd fails to open the mgetty log file /var/log/mgetty.<device>.log due to the default F19 security policy.
Comment 3 Michal Sekletar 2013-07-10 11:02:43 EDT
(In reply to mrj from comment #2)
> fails to open the mgetty log file /var/log/mgetty.<device>.log due to the
> default F19 security policy.

Can you please provide some logs. I am unable to reproduce the issue. I am running with SELinux enabled in enforcing mode and mgetty can create log files just fine. Thanks.
Comment 4 Michal Sekletar 2013-07-31 10:50:44 EDT
If you are still experiencing the issue please file a new bug. Thanks.

Note You need to log in before you can comment on or make changes to this bug.