Bug 85021 - Hwbrowser shows tree of disk partitions incorrectly.
Hwbrowser shows tree of disk partitions incorrectly.
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: hwbrowser (Show other bugs)
phoebe
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-24 17:07 EST by Peter van Egdom
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-25 17:30:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot 1 of tree situation (29.12 KB, image/png)
2003-02-24 17:08 EST, Peter van Egdom
no flags Details
Screenshot 2 of tree situation (36.12 KB, image/png)
2003-02-24 17:08 EST, Peter van Egdom
no flags Details

  None (edit)
Description Peter van Egdom 2003-02-24 17:07:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
When using the disk information facility in hwbrowser, the tree display
of the partitions on my harddrive gets incorrectly drawn.

(See attached screenshots for more information).

This is my partition lay-out :

Schijf /dev/hda: 120.0 GB, 120034123776 bytes
255 koppen, 63 sectoren/spoor, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

 Apparaat Opstart Start       Einde  Blokken  Id  Systeem
/dev/hda1   *         1      1020   8193118+   7  HPFS/NTFS
/dev/hda2          1021     11219  81923467+   7  HPFS/NTFS
/dev/hda3         11220     11232    104422+  83  Linux
/dev/hda4         11233     14593  26997232+   f  Win95 Ext'd (LBA)
/dev/hda5         11233     14463  25952976   83  Linux
/dev/hda6         14464     14593   1044193+  82  Linux wisselgeheugen



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start hwbrowser.
2. Click on disk information.
3. Play with the widgets.
4. Observe.
    

Actual Results:  Disk partition tree gets incorrectly drawn.

Expected Results:  Disk partition tree should be correctly drawn.

Additional info:

hwbrowser-0.8-9
Red Hat Linux release 8.0.94 (Phoebe)
Comment 1 Peter van Egdom 2003-02-24 17:08:16 EST
Created attachment 90325 [details]
Screenshot 1 of tree situation
Comment 2 Peter van Egdom 2003-02-24 17:08:49 EST
Created attachment 90326 [details]
Screenshot 2 of tree situation
Comment 3 Brent Fox 2003-02-25 17:30:48 EST
Fixed in cvs with the change below.  Can't rebuild packages at the moment, but
I'm closing as Rawhide anyway since I'll build new packages soon.


Update of /usr/local/CVS/hwbrowser
In directory elvis.redhat.com:/tmp/cvs-serv25551

Modified Files:
        DeviceDisk.py 
Log Message:
fix display of partitions

Index: DeviceDisk.py
===================================================================
RCS file: /usr/local/CVS/hwbrowser/DeviceDisk.py,v
retrieving revision 1.9
retrieving revision 1.10
diff -u -r1.9 -r1.10
--- DeviceDisk.py       7 Feb 2003 20:02:31 -0000       1.9
+++ DeviceDisk.py       25 Feb 2003 20:11:25 -0000      1.10
@@ -397,7 +397,10 @@
                            TYPE_COLUMN, type_text,
                            PARTITION_COLUMN, part)
             else:
-                physical = model.append(extended_parent)
+                if extended_parent:
+                    physical = model.append(extended_parent)
+                else:
+                    physical = model.append(parent_iter)
                 model.set (physical,
                            DEVICE_COLUMN, device_text,
                            START_COLUMN, start_text,

Note You need to log in before you can comment on or make changes to this bug.