This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 850211 - Introduce new systemd-rpm macros in mod_pubcookie spec file
Introduce new systemd-rpm macros in mod_pubcookie spec file
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mod_pubcookie (Show other bugs)
18
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gabriel Somlo
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 850016
  Show dependency treegraph
 
Reported: 2012-08-21 09:50 EDT by Lukáš Nykrýn
Modified: 2012-10-25 12:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 12:26:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lukáš Nykrýn 2012-08-21 09:50:17 EDT
Fedora 18 changes the way how to work with services in spec files. It introduces new macros - %systemd_post, %systemd_preun and %systemd_postun; which replace scriptlets from Fedora 17 and older (see https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd, https://bugzilla.redhat.com/show_bug.cgi?id=850016).
Comment 1 Gabriel Somlo 2012-10-25 12:26:26 EDT
I just orphaned mod_pubcookie, since it won't build against apache 2.4, upstream
has been dead for over a year, and my employer is moving away from it (in favor of shibboleth).

Given that, I believe it's safe to assume mod_pubcookie won't be around in f18, and therefore dealing with its systemd-related issues would be redundant...

Note You need to log in before you can comment on or make changes to this bug.