Bug 85023 - Verifying signatures w/ enigmail crash Mozilla
Verifying signatures w/ enigmail crash Mozilla
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: mozilla (Show other bugs)
phoebe
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-24 17:11 EST by Seth Ladd
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-25 14:39:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seth Ladd 2003-02-24 17:11:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030221

Description of problem:
This functionality was working with other distro's I've recently used, include
Mandrake 9 and Redhat 7.3.  I don't believe it's a enigmail bug for this reason.

I have installed enigmail 0.70.1, and while I can sign mail, if I click on an
email that has a signature, the entire mozilla process crashes immediately.  It
doesn't even get to render the email contents window.  It doesn't seem any core
file is left.  Everything goes away, mail, browsers, etc.

It seems to sign email fine, just doesn't want to verify.

Not sure if this is a bug w/ the mozilla included in pheobe, or just in how it
is configured and its interaction with enigmail.

I've also installed the mozilla rpms from rawhide (same version: 1.2.1) but that
didn't change anything.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Click an email that has been signed by some pgp/gpg.
2.boom.  mozilla gone.
3.
    

Actual Results:  No more mozilla anywhere.

Expected Results:  Mozilla to stay running and enigmail to display a little
icon.  At the very least, I want mozilla to stay up and some error messages
somewhere.

Additional info:
Comment 1 Christopher Blizzard 2003-02-25 14:39:16 EST
We don't even ship enigmail, so I can't support it.
Comment 2 Seth Ladd 2003-02-25 15:17:15 EST
OK, I understand.

But it's very odd that if I download mozilla 1.2.1 as a tarball from their site
and install enigmail, it works great.  But if I install enigmail onto pheobe's
mozilla 1.2.1, it barfs.

Thanks, though.
Comment 3 Christopher Blizzard 2003-02-25 21:09:35 EST
It might be a root vs. non-root thing.  Try installing it and then re-running
the mozilla-rebuild-databases.pl script.  And making sure that there aren't
files that were installed that are read-only as root.
Comment 4 Seth Ladd 2003-02-27 08:59:46 EST
Hi!

Thanks for the tips.  I ran rebuild-databases.pl as root, and now the enigmail
icons are gone from the UI.  It's also gone from the Preferences|Security menu.
 Odd...
Comment 5 Seth Ladd 2003-02-27 09:54:40 EST
Found Solution:

Get the RedHat RPMs from mozilla's site (http://ftp.mozilla.org).  They are
compiled with the same compiler that enigmail uses.  The crashes are due to
different compiler versions (one for redhat's included mozilla and one for
enigmail).

Thanks!

Note You need to log in before you can comment on or make changes to this bug.