Bug 850232 - Introduce new systemd-rpm macros in nss-pam-ldapd spec file
Introduce new systemd-rpm macros in nss-pam-ldapd spec file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nss-pam-ldapd (Show other bugs)
18
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 850016
  Show dependency treegraph
 
Reported: 2012-08-21 09:53 EDT by Lukáš Nykrýn
Modified: 2013-01-18 15:43 EST (History)
2 users (show)

See Also:
Fixed In Version: nss-pam-ldapd-0.8.12-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-18 15:43:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch replaces scriptlets with new systemd macros pro F18+ and RHEL7+ (3.40 KB, patch)
2012-11-29 05:05 EST, Václav Pavlín
no flags Details | Diff

  None (edit)
Description Lukáš Nykrýn 2012-08-21 09:53:11 EDT
Fedora 18 changes the way how to work with services in spec files. It introduces new macros - %systemd_post, %systemd_preun and %systemd_postun; which replace scriptlets from Fedora 17 and older (see https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd, https://bugzilla.redhat.com/show_bug.cgi?id=850016).
Comment 1 Václav Pavlín 2012-11-29 05:05:54 EST
Created attachment 654113 [details]
Patch replaces scriptlets with new systemd macros pro F18+ and RHEL7+
Comment 2 Nalin Dahyabhai 2013-01-18 15:43:36 EST
Looks like we missed the F18 release, but it's in for F19.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.