Bug 850285 - Introduce new systemd-rpm macros in qemu spec file
Introduce new systemd-rpm macros in qemu spec file
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
18
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 850016
  Show dependency treegraph
 
Reported: 2012-08-21 10:02 EDT by Lukáš Nykrýn
Modified: 2013-01-26 11:56 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-26 11:56:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
specfile patch to use the new macros (2.27 KB, text/plain)
2012-10-07 15:16 EDT, Cole Robinson
no flags Details

  None (edit)
Description Lukáš Nykrýn 2012-08-21 10:02:05 EDT
Fedora 18 changes the way how to work with services in spec files. It introduces new macros - %systemd_post, %systemd_preun and %systemd_postun; which replace scriptlets from Fedora 17 and older (see https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd, https://bugzilla.redhat.com/show_bug.cgi?id=850016).
Comment 1 Cole Robinson 2012-10-07 15:16:26 EDT
Created attachment 623095 [details]
specfile patch to use the new macros

Since this isn't urgent, I'm gonna hold off on this till F18 is out the door, since this will break building rawhide packages for F17 virt-preview:

http://fedoraproject.org/wiki/Virtualization_Preview_Repository
Comment 2 Fedora Update System 2013-01-16 13:20:49 EST
qemu-1.2.2-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qemu-1.2.2-2.fc18
Comment 3 Fedora Update System 2013-01-26 11:03:08 EST
qemu-1.2.2-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.