Bug 850350 - Xen PCI Passthrough does not work on latest kernel (kernel-3.5.2-1.fc17.x86_64)
Xen PCI Passthrough does not work on latest kernel (kernel-3.5.2-1.fc17.x86_64)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 10:14 EDT by jo4nsm1th
Modified: 2012-10-10 11:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-10 11:09:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jo4nsm1th 2012-08-21 10:14:10 EDT
Description of problem:
 Xen PCI Passthrough does not work on kernel-3.5.2-1.fc17.x86_64

Version-Release number of selected component (if applicable):
 kernel-3.5.2-1.fc17.x86_64

How reproducible:
 hardware requirements: system with vt-d support ( INTEL Core i7 2600 on INTEL DQ67SW for me)


Steps to Reproduce:
1. install fedora 17
2. Update system and install Xen
3. Boot fedora 17 (kernel-3.5.2-1.fc17.x86_64) in xen-hypervisor 
4. install domU system (Windows XP proffessional for me)
5. try to passthrough pci device (onboard usb controller for me)
  
Actual results:
pci device in domU does not work

Expected results:
pci device in domU work perfectly

Additional info:
if we boot kernel-3.3.4-5.fc17.x86_64 in xen-hypervisor then passthrough works fine
Comment 1 Konrad Rzeszutek Wilk 2012-08-30 14:58:33 EDT
Yup. The problem is that a patch in v3.5 causes MSI's to not be enabled for HVM PCI passthrough anymore. Working on it..
Comment 2 Konrad Rzeszutek Wilk 2012-09-11 07:40:48 EDT
Patch is in v3.6-rc4 and marked for stable. So it should show up in v3.5.x at some point,
Comment 3 jo4nsm1th 2012-09-25 11:57:42 EDT
kernel-3.5.4-1.fc17.x86_64 out but bug still not fixed.
Comment 4 Konrad Rzeszutek Wilk 2012-09-26 11:54:03 EDT
(In reply to comment #3)
> kernel-3.5.4-1.fc17.x86_64 out but bug still not fixed.

Yup. Just posted a patch yesterday to fix the last of the bugs (I hope):

http://lists.xen.org/archives/html/xen-devel/2012-09/msg02097.html
Comment 5 Fedora Update System 2012-09-27 12:25:42 EDT
kernel-3.5.4-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.5.4-2.fc17
Comment 6 Fedora Update System 2012-09-28 04:19:29 EDT
Package kernel-3.5.4-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.5.4-2.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14952/kernel-3.5.4-2.fc17
then log in and leave karma (feedback).
Comment 7 jo4nsm1th 2012-09-28 18:47:53 EDT
(In reply to comment #6)
> Package kernel-3.5.4-2.fc17:
> * should fix your issue,
> * was pushed to the Fedora 17 testing repository,
> * should be available at your local mirror within two days.
> Update it with:
> # su -c 'yum update --enablerepo=updates-testing kernel-3.5.4-2.fc17'
> as soon as you are able to, then reboot.
> Please go to the following url:
> https://admin.fedoraproject.org/updates/FEDORA-2012-14952/kernel-3.5.4-2.fc17
> then log in and leave karma (feedback).
Works for me.
Done.
Comment 8 Josh Boyer 2012-10-10 11:09:31 EDT
This is in the stable repo.  Not sure why bodhi didn't close the bug.

Note You need to log in before you can comment on or make changes to this bug.