Bug 850423 - [RHEVM] [UI] [webadmin] [Setup Host Networks] DC/CL 3.0 cannot confirm bond mode change on bond since there is no OK button
[RHEVM] [UI] [webadmin] [Setup Host Networks] DC/CL 3.0 cannot confirm bond m...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Moti Asayag
Martin Pavlik
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 10:48 EDT by Martin Pavlik
Modified: 2016-02-10 14:52 EST (History)
11 users (show)

See Also:
Fixed In Version: si17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:02:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot 1 (236.27 KB, image/png)
2012-08-21 10:48 EDT, Martin Pavlik
no flags Details
screenshot 2 (245.79 KB, image/png)
2012-08-22 04:04 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-08-21 10:48:28 EDT
Created attachment 605959 [details]
screenshot 1

Description of problem:
DC/CL 3.0 cannot confirm bond mode change on bond since there is no OK button when all available VLANs are assigned to bond

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: '3.1.0-12.el6ev' 

How reproducible:
100%

Steps to Reproduce:
1. Create one VLAN
2. Create bond from 2 NICs on host and assign VLAN to the bond
3. Edit the bond (screenshot 1) -> bond mode can be changed, but cannot be confirmed, there is no OK button
  
Actual results:
After all VLANs are assigned to bond there is no OK button to confirm bond mode change

Expected results:
If all VLANs are assigned to bond there is bond mode change OK button should appear


Additional info: this event does not produce logs
Comment 1 Alona Kaplan 2012-08-22 03:26:27 EDT
If you want to change the bond mode of a vlan assigned to a bond you have to select the vlan and then open the edit dialog.
As I see from your screenshot you selected the bond/nics and not the vlan.

Please check if when selecteting the vlan it works for you.
If yes, please close the bug.
Comment 2 Martin Pavlik 2012-08-22 04:04:08 EDT
(In reply to comment #1)
> If you want to change the bond mode of a vlan assigned to a bond you have to
> select the vlan and then open the edit dialog.
> As I see from your screenshot you selected the bond/nics and not the vlan.
> 
> Please check if when selecteting the vlan it works for you.
> If yes, please close the bug.

If I try to edit via selecting VLAN, bond mode is notr offered at all, please see screenshot 2.
Comment 3 Martin Pavlik 2012-08-22 04:04:30 EDT
Created attachment 606159 [details]
screenshot 2
Comment 4 Moti Asayag 2012-08-29 10:07:00 EDT
A suggested patch:

http://gerrit.ovirt.org/#/c/7577/

Note You need to log in before you can comment on or make changes to this bug.