This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 850430 - Allow users to hit enter after entering credentials instead of having to tab to register button during Subscription Manager Registration
Allow users to hit enter after entering credentials instead of having to tab ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Alex Wood
Entitlement Bugs
:
Depends On:
Blocks: 771481 840993
  Show dependency treegraph
 
Reported: 2012-08-21 11:07 EDT by Matt Reid
Modified: 2013-02-21 03:55 EST (History)
3 users (show)

See Also:
Fixed In Version: subscription-manager-1.1.6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:55:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-08-21 11:07:33 EDT
Description of problem:

We don't recognize hitting enter when users are entering credentials in subscription-manager, but do in our Classic tooling.

Registering through rhn_register register dialog:
1. User fills out username
2. fills out password
3. presses enter, dialog advances to next screen

Registering through subscription-manager register dialog:
1. User fills out username
2. fills out password
3. presses enter, waits for something to happen, nothing happens
4. presses tab 4 times to navigate to register button
5. presses enter

It would be nice to be consistent across these tools and allow them to hit enter after entering their credentials if they don't want to change anything else (this would skip over setting System Name & opting out of auto-subscribe in subscription-manager).
Comment 2 Alex Wood 2012-11-02 17:18:54 EDT
commit 0c44aea156da563d86cdfa1012ab52dfd65c0dfa
Author:     Alex Wood <awood@redhat.com>
AuthorDate: Fri Nov 2 14:48:51 2012 -0400
Commit:     Alex Wood <awood@redhat.com>
CommitDate: Fri Nov 2 14:56:26 2012 -0400

    850430: Pressing Enter in the password entry now activates registration.

    By setting the "Can Default" and "Has Default" properties on the
    register button and by setting the "Activates Default" property
    on the password entry field, we can make pressing Enter in the
    password entry field automatically begin the registration process.

Available in subscription-manager-1.1.6-1+
Comment 5 John Sefler 2012-11-17 11:51:02 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.1.9-1.el6.x86_64

The new enter key bindings while the focus is on the password field works great.
This function has been desired for a looooong time.  Thanks.


Note: This same binding does NOT apply in firstboot.
Comment 7 errata-xmlrpc 2013-02-21 03:55:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.